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PROGRAM VERIFICATION AND PRECAUTIONS 

MIDAS Family Programs produce accurate analysis results based on up-to-date theories and 

numerical techniques published in recognized journals. The program has been verified by 

thousands of examples and comparative analyses with other software during the development. 

Since the initial development in 1989, MIDAS Family Programs have been accurately and 

effectively applied to over 10,000 International projects. 

 

A strict verification process of the Computational Structural Engineering Institute of Various 

Countries has scrutinized MIDAS Family Programs. 

Due to the complexity of structural analysis and design programs which are based on extensive 

theories and design knowledge, the sponsors, developers and participating verification agencies do 

not assume any rights or responsibilities concerning benefits or losses that may result from using 

MIDAS Family Programs. The users must understand the bases of the program and the User’s 

Guide before using the program. The users must also independently verify the results produced by 

the program.  

 

DISCLAIMER 

The developers and sponsors assume no responsibilities for the accuracy or validity of any results 

obtained from MIDAS Family Programs (MIDAS/Gen, MIDAS/Civil, MIDAS/FEA, GTS NX, 

Soilworks, MIDAS/Design+ also referred to as "MIDAS Package" hereinafter). 

The developers and sponsors shall not be liable for loss of profit, loss of business, or any other 

losses, which may be caused directly or indirectly by using the MIDAS package due to any defect or 

deficiency therein. 

 

 

PREFACE 

Welcome to the MIDAS/Gen programs.   

MIDAS/Gen is a program for structural analysis and optimal design in the civil engineering and 

architecture domains. The program has been developed so that structural analysis and design can 

be accurately completed within the shortest possible time. The name MIDAS/Gen stands for 

General structure design. 
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▶Fig. 1.1  

Simply supported beam 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Eq. 1.1  

 
 
 
 
 
 
 
 
 
 
 

 

 
 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

그림 1.2 단면력 

 

 

 

 

                   1.1 Concept for Simple Beam 
Analysis 

Fig. 1.1 shows a simply supported beam in X-Z plane (2-D) in Global Coordinate System 

(GCS).  Element Coordinate System (ECS) x-axis is parallel with the span of the beam.  

ECS z-axis is as shown, and y-axis follows the right-hand rule.   
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A hinge support exists at the left end, and a roller support exists at the right end.  Each 

support is free to rotate about GCS Y-axis.  Equilibrium conditions require that the sums of 

forces are zeros.   

 

0,    0,    0    X Z YF F M  

 

A simply supported beam is statically determinate as the number of unknowns (𝐻𝐴, 𝑉𝐴 , 𝑉𝐵) 

equal to the number of equilibrium conditions (Eq. 1.1).   

 

Once the reactions are obtained, section forces can be found at a distance, x, which consist 

of axial force (𝑁(𝑥)), shear force (𝑉(𝑥)) and moment (𝑀(𝑥)).  The section forces are 

obtained from equilibrium in a free body diagram as shown in Fig. 1.2.  

  

1. Introduction 
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▶Fig. 1.2 

Simple beam subjected 
to a distributed load 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Eq. 1.2 

 
 
 
 
 
 
 
 
 
 

▶Fig. 1.3 

Section forces 
 
 
 
 
 
 
 
 

 
 
 
 
 
▶Fig. 1.2 

Section forces 
 
 
 
 
 
 
 
 
▶Eq. 1.2 

 
 
 
 
 
 
 
 
 
 
 

▶Fig. 1.3 

Section forces 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 1.4 

External load, shear & 
moment equilibrium 
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Fig. 1.3 represents the sign convention for + direction forces. 
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The infinitesimal length (𝑑𝑥) of the beam in Fig. 1.2 is isolated in Fig. 1.4 to represent an 

equilibrium condition in a free body diagram.  
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그림 1.5 단면에서의 변형-

변형률-응력 분포 

 

 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 

 

 
 

▶그림 1.5  

단면에서의 변형-변형률-

응력 분호 

 

 

 
 

 

 
 

식 1.4 

 

 
 

 

 
 

 

 
 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

식 1.5 

▶Eq. 1.3 

 
 

▶Eq. 1.4 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 1.5 

Section forces 
 
 
 
 
 

 
 

▶Eq. 1.5 

 
 

▶Eq. 1.6 
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Differentiating shear force becomes loading, and differentiating moment becomes shear 

force.  This means that the difference in shear forces is the same as the area of the 

distributed load between two points.  Also the difference in moments is the same as the area 

of shear force diagram between two points.  

External forces cause deformation, represented as displacement angle ( 𝜃𝑦 ) and 

displacement (ω).  The displacement angle at a point, x along the span is formed by the 

beam axes before and after deformation.  The beam axis after deformation is the tangent 

(differentiation) at the point x.   
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Displacement angle and displacement signify that axial deformation and shear deformation 

have taken place.  For a beam member where the span is relatively longer than the section 

dimensions, the shear deformation is negligibly small.   

 

In case of upward displacement in the z  direction as shown in Fig. 1.5, the top of the 

section is in tension and the bottom of the section is in compression.  Both tension and 

compression cause deformation perpendicular to the section in the x-direction, resulting in 

(𝑢(𝑧)) in Fig. 1.5.  Thus strain distribution (𝜀𝑥(𝑧)) in the axial direction is generated, and the 

curvature (∅𝑦 ) of the section deformation is obtained.  Differentiating the displacement 
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▶Eq. 1.6 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 1.6 

Simple beam subjected 
to a concentrated load 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

results in the displacement angle, and differentiating the displacement angle becomes the 

curvature.  Following the sign convention, the moment – curvature relationship and the 

moment – stress relationship can be derived from Fig. 1.5 as follows:   
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The reverse of Eq. 1.6 also holds true.  Integrating the curvature once becomes the 

displacement angle and integrating it once again results in displacement.  Hence the 

displacement angle and displacement can be derived from the moment distribution.   

 

Fig. 1.6 shows a simply supported beam subjected to a concentrated load at the mid span.  

The process of obtaining the displacement angle and displacement is reviewed. 
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Difference in shear forces between Points A and C is the area of the distributed load.  The 

fact that no distributed load exists between the 2 Points, shear force remains constant.  Also 

the difference in moments between the 2 Points is the shaded area of the shear force 

diagram, hence the moment at Point C becomes 𝑃1 4⁄ .  The displacement angle at Point 

A is the area of the curvature distribution (𝑀𝑦 / 𝐸𝐼𝑦 ) between Points A and C.  The 

displacement at Point C is the moment about Point A due to the area of the curvature 

distribution between Points A and C. 

 

Shear Force Diagram 

Moment Diagram 
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▶Fig. 1.6 

Simple beam 

subjected to a 

concentrated 

load 
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The above process of integrating the curvature once to obtain the displacement angle and 

twice to obtain the displacement is referred to as the moment – area method.  
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▶Fig. 1.7  

Analysis model 

2.1 Model Overview 

A beam is simply supported by a hinge at the left end and a roller at the right end.  

Deformation and member forces will be calculated using midas Gen and by hand.  
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 Material  

                 Concrete: 25 MPa (M25) (Modulus of elasticity E = 2.5 x 107 kN/m2)   

 Section  

                  Area: 0.8 m2  

                  Moment of inertia (Iy): 4.266667×10-2 m4    

  Load  

                  1. Model 1: uniformly distributed load 1.0 kN/m 

                  2. Model 2: concentrated load 10.0 kN  

 

 

 

Model 1: uniformly distributed load 

 

 

 

 

 

Model 2: concentrated load 

2. Tutorial 

1.0 kN/m 
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▶Fig. 1.8 

Save file &  
set unit system  
 
 
 
 
 
 
 

2.2 Work Environment 

Open a New File and save. 

 

Main Menu:  / New Project...  

Main Menu:  / Save As...  

1. File name: ‘Simple’ and [Save] 

 
 

Set a unit system to kN & m at the bottom of work window.  

 

 

Alternatively Main Menu:  
Tools / Unit System... 
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▶Fig. 1.9 

Set a work plane 
 
 
 
 
 

 

midas Gen is 3-D software.  Since the beam exists in a 2-D plane, X-Z plane in Global 

Coordinate System is set as the work plane, which restrains unnecessary degrees of 

freedom, DY (Y- displacement), RX (rotation about X - axis) and RZ (rotation about Z - axis).     

 

 

Main Menu: Structure / Structure Type...  

1. Structure Type > X-Z Plane  

2. [OK] 

 

 

 

  

1 

2 



 

 1 - 11 

Structural Analysis I  

(Basic) 

1. Simple Beam Analysis 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 1.10  

Define Material Data 
 
 
 
 

 
Properties can be directly 
input if Type of Design is 
set to User Defined. 
 
 
 
 

 
OK button closes the 
dialog box.  If multiple 
materials are defined, 
use Apply button. 

2.3 Material & Section Properties 

midas Gen contains a wide range of steel and concrete materials.  Material Data can be 

defined using Standard and DB or user-defined.  

 

 Main Menu: Properties / Material Properties 

1. [Add...]  

2. Name: ‘Concrete’  

3. Elasticity Data > Type of Design > Concrete  

4. Concrete > Standard > IS(RC), DB > M25 

5. [OK] 
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▶그림 1.13 축변형 

 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

▶그림 1.14 단면강도 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 1.11  

Define Section 
 
 
 

 
Consider Shear  
Deformation is generally 
checked on for structural 
analysis.  However, 
general structural 
mechanics hand 
calculation ignores 
shear deformation, 
which is the reason for 
checking off in this case 
for comparison 
purposes.    
 
 
 
 

 
[Show Calculation 
Results...] button 
invokes the 
automatically calculated 
Section Properties. 

 

midas Gen automatically calculates the section properties based on section dimensions. 

 

Main Menu: Properties / Section Properties, [Add...], 

1. Name: ‘Beam’  

2. Section shape list > Solid Rectangle, Section definition method > User 

3. H: ‘0.8’, B: ‘ 1’  

4. Ignore shear deformation: Consider Shear Deformation (Check off)  

5. [Show Calculation Results...]   

6. Check Section Properties, [Close] 

7. [OK]  

 

  

Area: cross sectional area 
Asy: local y - direction shear area 
Asz: local z - direction shear area 

Ixx: torsional constant 
Iyy: moment of inertia about local y – axis  
Izz: moment of inertia about local z – axis 
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▶Fig. 1.12  

Axial deformation 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 1.13  

Section stiffness 
 

 Material and Section 

When the load, P is applied in the axial direction of a beam,   takes place, which 

decreases with large magnitudes of modulus of elasticity (E) and cross sectional area (A). 

E



A

P

 

This can be expressed as,  

P EA
L P

EA
    

l
l

l
   

This can be also expressed in the form of load – displacement graph, where the slope (K ) 

is the stiffness of the structure, {D} = displacement, and {P} = applied load.  

 

 

 

 

When a program is used for structural analysis, results (forces, stresses, etc.) can be 

obtained from displacement. 

  

Structural analysis is a process in which loading and stiffness are defined to obtain the 

unknown displacement.  In midas Gen, loading is defined under the [Load] menu, and 

stiffness is defined under the [Model] menu. 

 

In the equation expressing the stiffness, [K], the numerator, {EA} is said to be Rigidity, which 

can be calculated by the material and section properties defined earlier.  Section stiffness is 

automatically calculated, which includes axial stiffness, bending stiffness, shear stiffness, 

torsional stiffness, etc.  All the parameters defining the Material and Section can be user – 

defined. 

Rigidity (Material, Section) 

Axial force               Bending                    Shear                      Torsion 

 

P



K

{P} {K} {D}      DKP 
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05.1 절점 생성 
 

 

 

 

 
 

 

 
 

 

 
 

 

 
 

 

 

 

 
 

 

 
 

▶그림 15 절점 생성 

 

 

 
Auto Fitting 을 Toggle on 하

면, 모델이 전체화면에 꽉차

게 들어오도록 실시간 자동

으로 Zoom Size를 조절한다. 

 

 

 

 
 

 

 
 

 

 
 

 

 

 
 

▶그림 1.16 절점 생성 

 

 

 

 

 
 
 
 

 
Finite element software 
like midas Gen models a 
structure with elements 
connected by nodes.  
 
midas Gen provides 
numerous element 
types, which include 
Truss element resisting 
only axial forces, Beam 
element resisting axial, 
shear and moment, and 
Plate element 
representing slabs and 
walls.     
 
Appropriate element 
types need to be used to 
reflect the structural 
behavior.  The smaller 
the element sizes, the 
greater is the accuracy 
of results.    
 
 
▶Fig. 1.14  

Create nodes 
 
 
                Element 
 
   Node                   Node 

 
Node  Element  Node 

 

2.4 Nodes & Elements Generation 

Create nodes where elements will be created. 

 

Main Menu: Node/Element / Create Nodes  

1. Coordinates (x, y, z): ‘0, 0, 0’  

2. To copy, Number of Times: ‘10’  

3. Distances (dx, dy, dz): ‘1, 0, 0’  

4. [Apply]  

5. Display Node Numbers, Auto Fitting, Front View (Toggle on) 
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▶Fig. 1.15  

Create elements 
 
 
 

 
Shrink View is used to 
identify the connectivity of 
the elements at nodes.  
The element separation 
in display confirms that 
the elements are 
connected to the nodes.   

 

Connect nodes to create elements. 

 

Main Menu: Node/Element / Create Elements 

1.  Element Type > General beam/Tapered beam 

2.  Material > 1:Concrete, Section > 1:Beam  

3. Click the Nodal Connectivity field (which turns to green), followed by clicking Node 1 

and 11 on the model view sequentially. 

4. Shrink, Hidden, Display Element Numbers (Toggle on) 

 

 

 

     Convenient option for creating elements 

 Node Snap: tracks the nodes when the mouse is placed close to the nodes on Model View. 

 Intersect Node: automatically divides the elements if nodes are present at the locations of the 

elements being created. 
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Create elements 
 
 

 
 

 

 
 

 

 
 

 

 

 

▶Fig. 1.15  

Create elements 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 1.16  

Copy elements 

 

 Copy the elements created. 

 

Main Menu: Node/Element / Translate Elements 

1. Mode > Copy 

2. Translation > Equal Distance > dx, dy, dz: ‘0, 0, 3’ 

3. Copy Node Attributes, Copy Element Attributes (Toggle on) 

4. Select All 

5.  [Apply] 
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▶Fig. 1.17  

Input support conditions 
 

2.5 Define Boundary Conditions 

Define support conditions, a hinge at the left end and a roller at the right end.  

 

Main Menu: Boundary / Define Supports 

1. Shrink, Display Element Numbers (Toggle off) 

2. Support Type > Dx, Dz (Check on)   

3. Select by Window (on) mode: select Nodes 1, 12 

4. [Apply]  

5. Support Type > Dx (Check off) 

6. Select by Window (on) mode: select Nodes 11, 22 

7. [Apply] [Close] 
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▶Fig. 1.18  

Simple beam reactions 
& degrees of freedom 
(local axes) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 1.19  

3-D shape 
 
 
 
 
 
 
 
 
 

▶Fig. 1.20  

Degrees of freedom in 
3-D (global axes) 
 
 
 
 
 

     Degrees of freedom in 3-D 

                                                                   

                                                        Hinge                                                                           Roller 

x

z

   

 

 

 

    6 Degrees of freedom in 3-D are shown below. 
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▶Fig. 1.21  

Define load case 
 
 
 

 
Typically in practice, a 
number of Load Cases 
(Types) are defined such 
as Dead Load, Live Load, 
etc., which will be 
combined with relevant 
load factors to satisfy a 
specific design code. 
 
 
 
 

2.6 Define Loads 

Define the load cases (load types) first to which individual loads will belong. 

 

Main Menu: Load / Static Loads / Static Load Cases 

1. Name: ‘Beam Load’  

2. Type > User Defined Load (USER) 

3. [Add] [Close] 
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▶Fig. 1.22  

Input the concentrated 
load 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

 

 

 
 

 

07.2 하중입력 

 

 

 

 

 

 

 

 

 

 
▶그림 19 집중 하중 입력 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
▶그림 20 Display 

 

 

 
입력된 값 확인 필요시 Display 

대화창 Load 탭에 Load Value

와 Nodal Load  Check On 하면 

확인할 수 있다. 

 

 
 
 

 

 
 

 

 

 

Input the concentrated load.  

 

Main Menu: Load / Static Loads / Nodal Loads 

1. Load Case Name > Beam Load 

2. Options > Add  

3. Nodal Loads > FZ: ‘-10’  

4. Select by Window (on) mode: select Node 6 

5. [Apply] [Close] 
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▶Fig. 1.23  

Define the distributed load 
 
 
 

 
 
Absolute: Extent of uniform 
load is applied in actual 
distance, x1, x2. 
(total length is 2m) 

 
  
 
 
 
 
 
 

 

Input the distributed load. 

  

Main Menu: Load / Static Loads / Element (Beam Load) 

1. Load Case Name > Beam Load 

2. Load Type > Uniform Loads 

3. Direction > Global Z  

4. Value > x1: ‘0’, w: ‘-1’, x2: ‘1’  

5. Display Node Numbers (Toggle off), Display Element Numbers (Toggle on) 

6. Select by Window (on) mode: select Elements 11-20 

7. [Apply] [Close] 
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▶그림 1.28 입력하중 검토 

 

 

 
 

 

 
 

 

 
 

 

 
 

 

 

 

 

 
 

 

 

▶그림 1.29 입력재질 검토 

 

 

 
 

 

 
 

 

 
 

 

 

▶그림 22 입력 데이터 확인 

 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

 

▶그림 23 입력 데이터 수정

법 

 

 

 

 
 

 

▶그림 1.27 Relative, Absolute 

 
 

 

 
 

 

 

 
 
 
 
 
 
 
 
 
 

▶Fig. 1.24  

Check loadings 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 1.25  

Check material data 
 
 
 
 
 
 
 
 

08.2 구조해석 수행 
 
 

 

 
 

 

▶그림 1.26  

해석 정상종료 메세지 

 
 

 

 
 

 

 

 2.7 Perform Analysis 

Check the modeling data using Works Tree.  Right-click the relevant list form Works Tree to 

invoke Context Menu to check and revise the input data. 

 

  

 

  

   

Works Tree 
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▶Fig. 1.26  

Message for a 
successful run 
 
 
 
 

 
Shortcut key for Perform 
Analysis is F5. 

 

Having checked the model, loadings and boundary conditions, analysis can be performed. 

 

Main Menu: Analysis / Perform Analysis   

1. Check for successful analysis in Message Window. 
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02.8.2 반력 
 

 

 
 

 

 
 

 

 
 

 

 

▶그림 1.30  

반력 결과 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 1.27 

Reaction results 

2.8 Check Analysis Results 

Check the reactions from midas Gen and compare them with hand calculations.  

 

Main Menu: Results / Reactions / Reaction Forces/Moments… 

1. Display Element Number (Toggle off) 

2. Load Cases / Combinations > ST: Beam Load 

3. Components > FXYZ  

4. Type of Display > Values, Legend (Check on) 

5. [Apply] [Close] 

 

 

 

Reactions from midas Gen, 5 kN are the same as those from hand calculations. 
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▶Fig. 1.28 

Displacements 
 
 
 
 
 
 
 
 
 
 

 
 

 

 
 

 

 

 

 

Check displacements from midas Gen and compare them with hand calculations. 

 

Main Menu: Results / Deformations / Displacement Contour… 

1. Load Cases/Combinations > ST: Beam Load 

2. Components > DXYZ  

3. Type of Display > Contour, Deform, Values, Legend (Check on) 

4. [Apply]  

5. Change the unit to mm in Status Bar at the bottom of the work screen. 

 

 

 

Hand calculations also show the same results (distributed load model: 0.124 mm, 

concentrated load model: 0.199 mm).  
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▶그림 1.32  

전단력(Fz) 결과 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 1.29 

Shear force (Fz)  

 

Check shear diagram and moment diagram.  

 

Main Menu: Results / Forces / Beam Diagrams... 

1. Change the unit to m in Status Bar at the bottom of the work screen. 

2. Load Cases/Combinations > ST: Beam Load 

3. Components > Fz  

4. Type of Display > Contour, Value, Legend (Check on), Deform (Check off) 

5. [Apply]  

6. Components > My  

7. [Apply]  

 

 

Hand calculations also show the maximum value of 5 kN. 
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▶Fig. 1.30 

Moment (My) 
 

 

 

 

Hand calculations also show the same results (distributed load model: 12.5 kNm, 

concentrated load model: 25 kNm). 
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▶Fig. 1.31 

Force components 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

 
 
 
 
 
 
 

▶Fig. 1.32 

Stress calculations 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Sax represents σAxial. 
 

 

 

 

 

 
▶그림 1.34  

부재력 성분 

 

     Force Components 
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▶Fig. 1.32 

Stress calculations 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Sax represents σAxial. 
 

 

 

Calculate the shear stress at the maximum shear at the supports and flexural stress at the 

maximum moment at the mid span.  

(1)

(10)

A(0.8)

I(0.04267)

S.F.D

B.M.D

5

12.5

Shear Stress

Bending Stress

y

VQ Ib(9.37)

My I(117.2)

 

 

 

 

                                                           

y

Q b

 

 

Stresses vary with the locations within the section.  

midas Gen produces stress at a point.  The stress output locations can be adjusted by 

inputting C (Cyp, Cym, Czp, Czm) and y, z (y1-4, z1-4). 

 

cym cyp

czp

czm
y

z
 Czp  

Czm 

 
Cym  Cyp 
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▶Fig. 1.33 

Stress components 

 

     Stress Components 

For a given Element Coordinate System as below, the stress sign convention and 

calculations are as follows:  

 

where,    Fx, Fy, Fz: axial force in x – dir., shear in y – dir., shear in z – dir. 

                 Iyy, Izz: moment of inertia about y – axis and z - axis 

                 Qyb, Qzb:  shear coefficient for y – axis and z - axis 

                 My, Mz:  moment about y – axis and z - axis 

                 Cy, Cz:  extreme fiber distance in y – dir. and z – dir.  

xy

z
1

2

3
4

 

 

Sax  axial stress 
P

A
 Fx

Area
 

Ssy  
shear stress in 

weak axis VQ

Ib
 

Fy

Izz
Qzb 

Ssz  
shear stress in 

strong axis 

Fz

Iyy
Qyb 

Sby  
moment about 

weak axis  My

I
 

Mz
Cy

Izz


 

( Max(Cyp,Cym) ) 

Sbz  
moment about 

strong axis 

My
Cz

Iyy
  

Combined  combined stress 
P My

A I
  

Fx Mz My
y z

Area Izz Iyy
     

( y1 ~ y4 ) 
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Check shear and flexural stresses due to the distributed load. 

 

Main Menu: Results / Stresses / Beam Stresses Diagram... 

1. Load Cases/Combinations > ST: Beam Load 

2. Components > Ssz  

3. Type of Display > Contour, Values, Legend (Check on) 

4. [Apply]  

5. Components > Sbz  

6. [Apply]  

 

 

  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 1.34 

Shear stress 
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▶Fig. 1.35 

 Flexural stress 

 

▶그림 1.38 휨응력 결과 
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Displacements for the uniformly distributed load and the concentrated load are the same 

as those from midas Gen (or midas Civil).  

(unit: kN, m with shear deformation ignored) 
 

 

(10)P

(10) 10

3P 48EI(0.1893mm)
45 384EI 0.1183mm 

1 

            

10P 

10 (10)

3P 48EI 0.1893mm
45 384EI(0.1183mm)

(1)

  

 

 

Member forces for the 2 loading conditions are also in agreement with those from midas 

Gen or midas Civil. 
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▶Fig. 1.36  

 Displacement results 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 1.37  

Reactions 
 
 
 
 
 

▶Fig. 1.38  

Shear forces 
 
 
 
 
▶Fig. 1.39  

Bending moments  

3. Manual Calculations 
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The following 2 beams are simply supported with a roller support on the left and a roller 

support on the right.  Find the displacements, reactions, shear forces and bending moments 

for each beam (ignore the shear deformation). 

 

 

                          

1.0 kN

5 m 5 m

 

 

                         

10 kN

4 m

10 kN

3 m 3 m

 

 

 

 Material  

                 Concrete: 25 MPa (M25) (Modulus of elasticity E = 25 kN/m2) 

   

  Section  

                  Area: 3.0×10-1 m2 (400×750) 

                  Moment of inertia (Iy): 1.40625×10-2 m4  

   

  Load  

                  1. Model 1: partial uniformly distributed load 1.0 kN/m  

                  2. Model 2: concentrated loads 10.0 kN at 2 points  

 
 

 
 

 

 

 

 

 

 

 

4. Exercise 

Model 1 

 

 

 

 

Model 2 
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▶Fig. 2.1 

Cantilever beam 

1.1 Concept for Cantilever Beam 
Analysis 

A cantilever beam is a statically determinate structure.  Fig. 2.1 shows a cantilever beam on 

Global Coordinate System (GCS) X-Z plane, which is restrained at the left end, A with 

horizontal and vertical translations and rotation.  

 

 

X

Y
Z

A

AV

AH

AM
B

z

x

 
 

Once the reactions of the beam are obtained, section forces at a specific location, x, along 

the span can be found by equilibrium.  3 Force components, axial force (𝑁(𝑥)), shear force 

(𝑉(𝑥)) and moment (𝑀(𝑥)) can be found from a free body diagram as shown in Fig. 2.2(b) 

satisfying equilibrium.   

1. Introduction 
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▶Fig  2.2  

Section force 
 
(a) Cantilever beam 
 
 
 
 
 
 
 
 
 
 
 
 
(b) Free body diagram  
 
 
 
 
 
 
 
 
 
 

▶Eq. 2.1 
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The relationship of loading-shear force-moment and the relationship of deformation-strain-

stress at a particular section of a cantilever beam are identical to those of a simply supported 

beam.  

 

In order to demonstrate the relationship of displacement-displacement angle-curvature of a 

cantilever, a simple beam with the span of l  and a cantilever beam with the span of 2l  

are examined.  Both cases are subject to a constant moment.  Provided that the modulus of 

elasticity and the section dimensions are constant, the curvature remains constant.  In this 

case, the mid span displacement and the end displacement angle of the simple beam are 

identical to the displacement and displacement angle at the free end of the cantilever beam 

respectively.  
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▶Fig. 2.3  

Simple beam & 
cantilever beam 
 
 
 
 
 
 
 

▶Eq. 2.2 

 

The same magnitudes are caused by the fact that the shaded areas of the curvature, 𝑀𝑦/ 

𝐸𝐼𝑦 are identical in both beams.  The displacement angle is the area of the shaded part, and 

the displacement corresponds to the moment of the shaded area.
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For simplicity, signs for the displacement angle and displacement are omitted.   

 

The same deformation value for the simple beam and the cantilever beam can be also 

identified by the deformed shapes.  The deformed shape of the right half span of the simple 

beam is identical to that of the cantilever beam.  The tangent of the deflection at the mid span 

of the simple beam is zero, which exhibits the effect of a fixed end.   
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▶Fig. 2.4  

Analysis models 

2.1 Model Overview 

 

The following cantilever beam is subject to a concentrated load and a uniformly distributed 

load.  Reactions, displacements and member forces will be calculated. 

 

1.0 kN

5 m

5 kN

5 m

 
 

1.0 kN

5 m

5 kN

5 m

 
 

 

 Material  

Steel: Fe440 (Modulus of elasticity, E = 2.05×108 kN/m2)  

 Section  

Area:  6.671×10-3 m2 (ISMB 350) 

Moment of inertia (Iy): 1.363030×10-4 m4  

 Load  

Model 1: concentrated load 10 kN  

Model 2: uniformly distributed load 1.0 kN/m 

 

 

 

 

Model 1: concentrated load 

 

 

 

 

 

 

 

Model 2: uniformly distributed load 

2. Tutorial 



 

 

2. Cantilever Beam  

2 - 7 

Structural Analysis I  

(Basic) 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 2.5  

Save file & 
set unit system  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

2.2 Work Environment 

 

Open a New File and save. 

 

Main Menu:  / New Project...  

Main Menu:  / Save As...  

1. File name: ‘Cantilever’ and [Save]  

 

 

Set a unit system to kN & m at the bottom of work window. 

  

 

Alternatively Main Menu:  
Tools / Unit System... 
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▶Fig. 2.6  

Set a work plane  
 

 

midas Gen is 3-D software.  Since the beam exists in a 2-D plane, X-Z plane in Global 

Coordinate System is set as the work plane, which restrains unnecessary degrees of freedom, 

DY (Y- displacement), RX (rotation about X - axis) and RZ (rotation about Z - axis).   

 

Main Menu: Structure / Structure Type 

1. Structure Type > X-Z Plane  

2. [OK]  
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04.2 단면정의 

 
 

 

 
 

 

 
 

 

 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 2.7  

Define Material Data 
 

2.3 Material & Section Properties 

 

 

Select Fe440 from DB. 

 

Main Menu: Properties / Material Properties 

1. [Add...]  

2. Name: ‘Fe440’  

3. Type of Design > Steel  

4. Steel > Standard > IS(S), DB > Fe440 

5. [OK]  
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▶Fig. 2.8  

Define section 
 
 
 

 
Consider Shear  
Deformation is 
generally checked on 
for structural analysis.  
However, general 
structural mechanics 
hand calculation 
ignores shear 
deformation, which is 
the reason for 
checking off in this 
case for comparison 
purposes. 
 
 

 

Use IS355   Click Section tab.  

 

1. [Add...]  

2. Section shape list > I-Section  

3. Section definition method > DB, DB > IS(S)  

4. Sect. Name > ISMB 350  

5. Consider Shear Deformation (Check on)  

6. [OK]  

 

 

 

 

  

1 
2 

 

3 

5 

6 

4 



 

 

2. Cantilever Beam  

2 - 11 

Structural Analysis I  

(Basic) 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 2.9  

Create nodes 

2.4 Nodes & Elements Generation 

 

 

Create nodes where elements will be created. 

 

Main Menu: Node/Element / Create Nodes  

1. Coordinates (x, y, z): ‘0, 0, 0’   

2. Copy > Number of Times: ‘5’  

3. Distance (dx, dy, dz): ‘1, 0, 0’  

4. Display Node Numbers, Display Element Numbers (Toggle on) 

5. [Apply]  

6. Auto Fitting, Front View (Toggle on) 

 

 

  

5@1.0 = 5.0 m 
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▶Fig. 2.10  

Create beam elements 

 

 Connect nodes to create elements. 

 

Main Menu: Node/Element / Create Elements  

1. Element Type > General beam/Tapered beam   

2. Material > 1: Fe440 

3. Section > 1: ISMB350 

4. Intersect > Node, Elem (Check on) 

5. Click the Nodal Connectivity field (which turns to green), followed by clicking Node 1 

and 6 on the model view sequentially. 

6. Hidden (Toggle on) 
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▶Fig. 2.11  

Copy elements 

 

Copy the elements created with the same properties.  

 

Main Menu: Node/Element / Translate Elements  

1. Mode > Copy  

2. Translation > Equal Distance 

3. dx, dy, dz : ‘0, 0, 2’, Number of Times: ‘1’  

4. Select All 

5. [Apply]  
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▶Fig. 2.12  

Input support 
conditions 
 

2.5 Define Boundary Conditions 

 

midas Gen is 3-D software in which each node retains 6 degrees of freedom (Dx, Dy, Dz, 

Rx, Ry, Rz) symbolized by 6 triangular cells in a hexagon.  Dx to Rz are sequentially 

represented starting from the “12 o’clock” in the clockwise direction.  Green color in the 

triangular cells signifies restrained condition. 

 

Main Menu: Boundary / Define Supports  

1. Display Element Numbers (Toggle off)  

2. Support Type > Dx, Dz, Ry (Check on) 

3. Select Single (on) mode: select Nodes 1, 7 

4. [Apply] 
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▶Fig. 2.13  

Define load case 
 
 
 
 
 
 

 
Typically in practice, a 
number of Load Cases 
(Types) are defined 
such as Dead Load, 
Live Load, etc., which 
will be combined with 
relevant load factors to 
satisfy a specific design 
code. 
 
 

2.6 Define Loads 

 

Define the load cases (load types) first to which individual loads will belong. 

 

Main Menu: Load / Static Loads / Static Load Cases  

1. Name: ‘Beam Load’ 

2. Type > User Defined Load (USER) 

3. [Add] 

4. [Close] 
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▶Fig. 2.14  

Input loads 

 
 
 
 
 
 
 

 

Input a concentrated load of 10 kN at the tip of the cantilever, Node 12. 
 

Main Menu: Load / Static Loads / Nodal Loads 

1. Load Case Name > ‘Beam Load’  

2. Nodal Loads FZ: ‘-10’  

3. Select Node 12  

4. [Apply] [Close] 

 

Input a uniformly distributed load of 1.0 Kn/m. 

 

Main Menu: Load / Static Loads / Element (Beam Load) 

1. Load Case Name > ‘Beam Load’  

2. Load Type > Uniform Loads   

3. Value > x1: ‘0’,  w: ‘-1’, x2: ‘1’  

4. Display Element Numbers (Toggle on)  

5. Select Elements 1, 2, 3, 4, 5  

6. [Apply] [Close] 

 

 

 

 

 

 

 

 

 

 

2.7 Perform Analysis 
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Check the modeling data prior to performing analysis. 

 

Main Menu: View / Display… 

1. Load tab, Load Case > Load Value (Check on) 

2. Case Selection > ST: Beam Load  

3. From the list, check on Nodal Load, Beam Load  

4. [OK]  

 

Main Menu: View / Display 

5. Nodal Load, Beam Load (Check off) 

6.  [OK]  
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▶Fig. 2.16  

Message for a 
successful run 
 
 
 
 
 
 
 
 

 
Shortcut key for 
Perform Analysis is F5. 
 
Error messages will be 
generated in Message 
Window if the input 
data contains errors.  
 

  

Analysis is performed. 

Main Menu: Analysis / Perform Analysis 

1. Display Node Numbers, Display Element Numbers (Toggle off) 

2. Check for successful analysis in Message Window. 
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02.8.1  
Reactions 
 
 
 

 
 
 
 
 
 
 
 

▶Fig. 2.17  

Reaction results 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 2.17  

Reaction results 

2.8 Check Analysis Results 

 

Check the reactions from midas Gen and compare them with hand calculations. 

 

Main Menu: Results / Reactions / Reaction Forces/Moments… 

1. Load Cases/Combinations > ST: Beam Load  

2. Components > FXYZ  

3. Type of Display: Values, Legend (Check on) 

4.  [Apply] [Close] 
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▶Fig. 2.18  

Displacements 

  

Check displacements from midas Gen and compare them with hand calculations. 

 

Main Menu: Results / Deformations > Displacement Contour… 

1. Load Cases/Combinations > ST: Beam Load 

2. Components > DXYZ 

3. Type of Display > Contour, Deform, Values, Legend (Check on)  

4. [Apply] [Close] 

5. Change the unit to mm in Status Bar at the bottom of the work screen. 
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Max: 15.135 

Max: 2.852 
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▶Fig. 2.19  

Moment results 
 
 
 

 
부재력은 요소좌표계에 

따라 출력되며, 기본값일 

경우 선요소(보, 기둥)의 

휨모멘트는 My, 전단력

은 Fz, 축력은 Fx 로 출력

된다.  

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 2.19  

Moment 
 
 
 

 
Member forces are 
generated in Element 
Coordinate System.  For 
beam / column 
elements in 2-D, 
moment My, shear force 
Fz, and axial force Fx 
are generated. 

 

Check moment diagram. 

 

Main Menu: Results > Forces > Beam Diagrams...  

1. Change the unit to m in Status Bar at the bottom of the work screen.  

2. Load Cases/Combinations > ST: Beam Load  

3. Components > My  

4. Type of Display > Contour, Values, Legend (Check on), Deform (Check off) 

5. [Apply]  
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▶Fig. 2.20  

Shear force 
 
 
 
 

 

Check shear diagram. 

 

1. Components > Fz   

2. [Apply]  
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Max: -10.0 

Max: -5.0 
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Stresses 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 2.21  

Stress results 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 2.21  

Beam Stress 

 
 
 

 
 
 
 
 
 
 
 
 
 

▶Fig. 2.19  

Beam stresses 
 

 

Check member stresses.  

 

Stress components:  

        Sax: axial stress in ECS x – dir.  

        Ssy, Ssz: shear stress in ECS y – dir. and z – dir. respectively 

        Sby, Sbz: flexural stress about ECS y – axis and z – axis respectively  

        Combined: maximum or minimum of combined stresses, Sax ± Sby ± Sbz  

 

Stress component Sbz needs to be checked for pure flexural stress.  

 

Main Menu: Results > Stresses > Beam Stresses... 

1. Load Cases/Combinations > ST: Beam Load  

2. Components > Sbz  

3. Type of Display > Contour, Deform, Value, Legend (Check on)  

4. [Apply]  
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3.1.1 Reactions 
 
 
 
 
 

 
 
3.1.2 Displacements 
 
 

 
 
 
 
 
 
 
3.1.3 Shear forces 
 
 
 
 
 
 
 
3.1.4 Bending moments 
 
 

 

 

Reaction in Model 1 with a concentrated load, P = 10.0 kN 

Reaction in Model 2 with a uniformly distributed load, l  = 5.0 kN  

These are the same as the midas Gen results.  

 

 

Displacement in Model 1 with a concentrated load, 
3

 = 14.095 mm
3

P

EI
 

l
  

Displacement in Model 2 with a uniformly distributed load, 
4

 = 5.286 mm
8EI


 

l
 

These are the same as the midas Gen results.  

 

 

Shear force in Model 1 with a concentrated load, AV P 5 kN    

Shear force in Model 2 with a uniformly distributed load, kN5VA    

These are the same as the midas Gen results.  

 

 

Bending moment in Model 1 with a concentrated load, mkN25  PM  

Bending moment in Model 2 with a uniformly distributed load, 
2

12.5 kN m
2

    
l

M


 

These are the same as the midas Gen results. 

 

 

 

  

3. Manual Calculations 

-10 kN 

- 50 kNm 

-14.912 mm 
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Find the reactions, shear forces, bending moments and displacements for each beam 

below subject to the loadings shown (ignore the shear deformation).  

 

1.0 kN

5 m

5 kN

2.5 m 2.5 m

5 kN

 

 

2.0 kN / m

2.5 m

5 kN

5 m2.5 m

 

 

 

 Material  

Steel: Fe440 (Modulus of elasticity, E = 2.05×108 kN/m2) 

 Section  

Area:  6.671×10-3 m2 (ISMB 350) 

Moment of inertia (Iy): 1.363030×10-4 m4  

 Load  

Model 1: concentrated loads 5.0 kN  

Model 2: partial uniformly distributed load 2.0 kN/m 

 

 

Model 1: concentrated loads 

 

 

 

 

 

 

 

Model 2: partial uniformly distributed 

load 

4. Exercise 
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▶Photo 3.1  

 (a) Roof trusses 
 (b) Long span bridge 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig 3.1  

Examples of truss types  
 
 

 
 
 
 
 
 
 
 
 
 
 

02.1 일반사항 

 
 

 

 

 

▶그림 1 단순보 

 

 

 

 

▶그림 2 단순라멘교 

 

 
▶그림 3 단순보 해석 

 

 

 

 

 

 

 

 

 

 

02.2 학습내용 

 

 

 

 

▶그림 4 수계산 

▶그림 5 프로그램 해석결과 

1.1 Concept for Truss Analysis 

 

A truss generally consists of 2 or more chords connected by a series of hinged diagonals and 

verticals in the form of triangles.  The truss type structural system is used for long span 

applications while minimizing the own weight, which include plants, auditoriums, sports 

arenas, stadiums and bridges. 

 

  

 

 

Depending on application areas, trusses can be of many different shapes and forms, which 

include roof truss, truss beam, truss supported by columns, truss frame, etc. 

  
(a) (b) 

  

  
(c) (d) 

  

1. Introduction 
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▶Fig. 3.2  

External force Internal 
force  Node 
 
 
 
 
 
 
 
 
 
 
 
 
 

Truss forces are found under the following assumptions:  

1) Members joining at each node are hinge-connected. 

2) Each member is straight. 

3) The centerlines of the members meet at nodes. 

4) Loadings are applied only at the nodes.   

 

Since only nodal loadings are present, truss member forces are either only in tension (+) or 

in compression (-).  Tension is defined when external and internal forces act away from a 

node.   

 

  

 

 

A truss structure can be statically determinate or indeterminate.  A statically indeterminate 

truss can be further classified as external and internal.  A statically determinate truss is one 

that reactions and member forces can be calculated from only equilibrium, whereas additional 

conditions corresponding to the degree of indeterminacy are required for analyzing a statically 

indeterminate truss.  Force equilibrium conditions alone cannot obtain the reactions of an 

externally indeterminate structure.  For an internally indeterminate structure, reactions can be 

found by force equilibrium, but additional conditions are required for obtaining the member 

forces.    

 

The degree of indeterminacy of a 2-D truss is determined as below; 

Degree of external indeterminacy:  𝑚𝑒 = 𝑛 − 3 

Degree of internal indeterminacy: 𝑚𝑖 = (3 + 𝑠 + 𝑟) − 2𝑘  

Total degree of indeterminacy: 𝑚 = 𝑚𝑒 + 𝑚𝑖 

where,  

𝑛: number of unknown reaction components,  

𝑠: number of members,  

𝑟: number of rigidly connected nodes,  

𝑘: number of nodes 
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▶Fig. 3.3 

Truss cuts  
 
 
 

1) Solutions for statically determinate truss structures 

 

A truss can be analyzed by the methods of joints (nodes), sections, stress coefficients, 

drawings, influence lines, etc.  Among these methods, the joint method entails force 

equilibrium in a joint free body diagram like ∑ 𝐹𝑋 = 0 , ∑ 𝐹𝑍 = 0 .  The section method 

involves force equilibrium of the free body diagram of a cut truss satisfying ∑ 𝐹𝑋 = 0 , 

∑ 𝐹𝑍 = 0, ∑ 𝑀 = 0.  The moment sum of force equilibrium is missing from the joint method 

as a truss node cannot resist moments. 

 The diagrams below illustrate the joint and section methods.  Nodal equilibrium at the joint 

(node) A is shown in the joint method.  The section method shows a cut truss to which force 

equilibrium is applied.  The fact that 2 equations can be used for the joint method, no more 

than 2 members can be connected.  Similarly 3 equations can be used in the section method, 

hence the number of the cut members should be limited to no more than 3.   
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Cut line 
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▶Fig. 3.4 

Flexibility method 
(a) Analysis model 
 
 
 
 
 
 
 
 
(b) Case of an external 
load applied 
 
 
 
 
 
 
 
 
 
 
(c) Case of a unit load 
applied to BF member 
 
 
 

2) Solutions for statically indeterminate truss structures 

 

The method of consistent deformation or the flexibility method is useful in analyzing 

indeterminate truss structures.  In the method of consistent deformation, equations are 

formulated for the degrees of freedom selected as unknowns, and compatibility conditions 

are applied. 

  

The structure below illustrates the flexibility method in which one degree of freedom is 

selected as an unknown.  The BF truss member in the example is artificially heated up to 

elongate its length by ∆.  The concept of flexibility method is explained for the unknown 

member force in BF,  𝑋1.  

 

A
H

D
V

A
V

B C

E

D

F

A

( )a
 

 
( )b

B C
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D

F
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( )c

E F
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1 1

 

  

Change in length due to a 

change in temperature  

1D
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▶Eq. 3.1 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Eq 3.2 

 

In the flexibility method or the method of consistent deformation, analysis is carried out by 

establishing a compatibility condition for the state of removed member or support selected as 

an unknown.  If the BF member force is selected as an unknown, the compatibility condition 

corresponds to the state of the member cut in the middle.  The change in distance (overlap 

or separation) between the two disconnected points due to an external load is defined as 𝐷1.  

Note that a change in temperature is not an external load.  And the change in distance 

between the two disconnected points due to a unit load is defined as 𝑓11.  Then,  𝑓11 𝑋1 

represents the distance between the two disconnected points in the BF member subjected 

to a member force, 𝑋1.  The compatibility condition in this case then becomes,  

 

11 1 1 1f X D    

 

If only a loading is present without a temperature-like cause, ∆1becomes zero.  But if the 

member BF undergoes a change in length due to a temperature effect, 𝐷1 becomes zero, 

and ∆1 becomes the change in length.  That is, the above equation expresses the 

compatibility condition for the fact that the member BF is not at the disconnected state.  

Because 𝑓11 𝑋1 and 𝐷1cancel each other or the actual deformation is ∆1, it is also referred to 

as the method of consistent deformation.  The unit load is the most effective method of finding 

the deformation 𝑓11  or 𝐷1among other methods.   

  

When a structure has the degree of indeterminacy of 2, 2 members or reactions are selected.  

The following compatibility conditions can be formulated for the state of removed members 

or reactions:  

11 12 1 1 1

21 22 2 2 2

11 12 21 22

1 2

1 1 1 2 2 2

1 2

,    ,   

,  
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∆𝑖= Deformation due to erection tolerance or temperature change, etc. 
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▶Fig. 3.5  

Analysis model 
 
 
 
 
 
 
 
 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

▶그림 3.7  

해석모델 

2.1 Model Overview 

 

Compare the behaviors of the two trusses, one truss with the degree of internal indeterminacy 

of 1, and the second truss with each degree of internal and external indeterminacy of 1.  Both 

cases are subject to an internal load like an erection tolerance and a concentrated load.   

 

Model 1: Degree of internal static indeterminacy of 1 

P 500 kN

5 mm

8
.0

 m

3@6m 18.0 m

X

Z

 

 

Model 2: Degree of internal and external static indeterminacy of 1 each 

P 500 kN

5 mm

8
.0

 m

3@6m 18.0 m

X

Z

 

 

 Material: Fe540 (Modulus of elasticity, E = 2.050×108 kN/m2) 

 Section: SHS 250 X250X12 mm 

 Load 

1. Concentrated nodal load: 500 kN 

2. Erection tolerance: 5 mm → converted into a pretension load (1133.035 kN) 

             P = K = EA/ l × = (2.0500×108×0.011054/10)×0.005 = 1133.035 kN 

  

2. Tutorial 



 

 

3. Truss Analysis Structural Analysis I  

(Basic) 

3 - 9 

 

 

 
 

 

 
 

 

 
 

 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 3.6  

Save file & 
set unit system 
 

 
 

 

 
 

 
 
 
 

02.2.1  
Set a unit system 
 
 
 
 
 
 
 
 

 
▶Fig. 3.6  

Save file &  
set unit system 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 6.8 

Save file &  
set unit system 
 
 

2.2 Work Environment 

  

Open a New File and save.  

 

Main Menu:  / New Project...  

Main Menu:  / Save As...  

1. File name: ‘Truss’ and [Save]  

 

Set a unit system to kN & m at the bottom of work window. 

 

   

Alternatively Main Menu: Tools / Unit System... 
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▶Fig. 3.7 

Set a work plane 
 
 
 
 

02.2.2  
Set a work plane 
 

 

 

 

 

 

 

 

 

 
 

 

▶Fig. 3.9  

Set a work plane 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The example models exist in the 2-D X-Z plane.   

 

Main Menu: Structure / Structure Type...  

1. Structure Type > X-Z Plane  

2. [OK]  
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▶Fig. 3.8 

(a) Define material 
(b) Define section 
 
 
 

2.3 Material & Section Properties 

 

Select Fe540 from DB. 

 

Main Menu: Properties > Material Properties 

1. [Add...]  

2. Name: ‘Fe540’  

3. Type of Design > Steel  

4. Steel > Standard > IS(S), DB > Fe540 

5.  [OK]  

 

Click Section tab. 

1. [Add...]  

2. Section shape list > Box 

3. Sect. Name > SHS 250 X250X12 

4. [OK] [Close]  
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02.4.1 
Create nodes 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 3.11  

Create a node 
 
 
 
 
 
 
 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 3.9 

Create a node 
 
 
 

2.4 Nodes & Elements Generation 

 

Create nodes where elements will be created. 

  

Main Menu: Node/Element > Create Nodes 

1. Coordinates (x, y, z): ‘0, 0, 0’  

2. [Apply]  

3. Auto Fitting, Front View (Toggle on) 

 

 

 

 

 

 

  

1 
3 

3 

2 



 

 

3. Truss Analysis Structural Analysis I  

(Basic) 

3 - 13 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 3.10 

Create a bottom chord 

 

Use Extrude Elements to extrude a node into line elements for the bottom chord.  

 

Main Menu: Node/Element > Extrude  

1. Extrude Type > Node → Line Element  

2. Element Attribute > Element Type > Truss  

3. Material > ‘1:Fe540, Section > 1: SHS 250 X250X12, Beta Angle: ‘0’  

4. Generation Type > Translate 

5. Translation > Equal Distance  

6. dx, dy, dz: ‘6, 0, 0’, Number of Times: ‘3’  

7. Select All to select the node 

8. [Apply] 
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▶그림 3-13  

상현재 생성 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 3.11 

Create top chord 

 

Copy the bottom chord to create the top chord.  

 

Main Menu: Node/Element > Translate Elements  

1. Mode > Copy 

2. Translation > Equal Distance  

3. dx, dy, dz: ‘0, 0, 8’, Number of Times: ‘1’ 

4. Display Element Numbers (Toggle on) 

5. Select Single (on) mode: select Element 2 

6. [Apply]  
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▶Fig. 3.12 

Create diagonals and 
verticals 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 

▶그림 3.12 

사재 및 수직재 생성 

 

Input the diagonals and verticals.  

 

Main Menu: Node/Element / Create Elements 

1. Element Type > Truss 

2. Material > 1:Fe540, Section > 1: SHS 250 X250X12  

3. Intersect > Elem (Check off)   

4. Display Node Numbers (Toggle on), Display Element Numbers (Toggle off) 

5. Click the Nodal Connectivity field (which turns to green) 

6. Click Nodes 1 and 5 on the model view sequentially. 

7. Click Nodes (5, 2), (2, 6), (5, 3), (6, 3), (6, 4) sequentially 
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▶그림 3.15  

지점조건 입력 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 3.13 

Define support conditions 

2.5 Define Boundary Conditions 

 

 

In 3-D, each node retains 6 degrees of freedom (Dx, Dy, Dz, Rx, Ry, Rz).  But with the work 

plane being on X-Z plane, only 3 degrees of freedom (Dx, Dz, Ry) exist, among which the Dx, 

Dz degrees of freedom are restrained for the pin support, and the Dz degree of freedom is 

restrained for the roller support. 

  

Main Menu: Boundary / Define Supports 

1. Options > Add, Support Type > Dx, Dz (Check on)  

2. Select Single (on) mode: select Node 1, [Apply] 

3. Support Type > Dx (Check off) 

4. Select Single (on) mode: select Node 4, [Apply]  

 

 

 

  

Roller support 

1 

1,3 

2,4 

Pin support 

2 4 
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▶Fig. 3.14  

Define load cases 
 

2.6 Define Loads 

 

Define the load cases for a nodal concentrated load and a pretension load representing the 

erection tolerance individually.  

  

Main Menu: Load / Static Loads / Static Load Cases 

1. Name: ‘Nodal Load’, Type > User Defined Load, [Add] 

2, Name: ‘Erection Tolerance’, Type > User Defined Load, [Add] 

3. [Close]  

 

 

 

  

2 

3 



 

 

3. Truss Analysis Structural Analysis I  

(Basic) 

3 - 18 

07.2 절점하중 입력 

 
 
 
 
 
 
 
 
 
 

▶그림 3-17  

절점하중 입력 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 3.15 

Input nodal load 

 

Input the concentrated load, 500 kN at Node 2. 

  

Main Menu: Load / Static Loads / Nodal Loads 

1. Load Case Name > Nodal Node, Options > Add  

2. Nodal Loads > FZ: ‘-500’ kN  

3. Select Single (on) mode: select Node 2 

4. [Apply] 
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▶Fig. 3.16 

Input pretension load 

02.6.3 조립오차 입력 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶그림 3.16 

프리텐션하중 입력 

 

If the member length is fabricated 5 mm shorter than the true length, tension is introduced in 

the corresponding member during erection.  Such fabrication error is converted into a 

pretension load. 

P = K = EA/ l × = (2.050×108×0.011054/10)×0.005 = 1133.035 kN 

  

Main Menu: Load / Temp./Prestress / Pretension Loads 

1. Load Case Name > Erection Tolerance 

2. Options > Add  

3. Pretension Load: ‘1133.035’ kN 

4. Display Node Numbers (Toggle off), Display Element Numbers (Toggle on)  

5. Select Single (on) mode: select Element 8 

6. [Apply]  
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▶그림 3-19  

요소 복제 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 3.17 

Copy elements 

 

Copy Model 1 to create Model 2.  In order to also copy the nodal load, pretension load and 

boundary conditions, check on Copy Node Attributes and Copy Element Attributes. 

  

Main Menu: Node/Element / Translate Elements 

1. Mode > Copy  

2. Translation > Equal Distance  

3. dx, dy, dz: ‘0, 0, -14’, Number of Times: ‘1’  

4. Copy Node Attributes, Copy Element Attributes (Check on) 

5. Select All 

6. Display Node Numbers (Toggle on), Display Element Numbers (Toggle off)   

7. [Apply] [Close] 
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▶Fig 3.18 

Change support condition 

 

Model 2 is an externally static indeterminate structure for which the roller condition is revised 

to a pinned condition by additionally assigning the Dx degree of freedom.  

  

Works Tree: Right-click on Type 2 [001000] under Boundaries – Supports: 4  

and click Display 

 

Main Menu: Boundary / Define Supports  

1. Options > Add  

2. Support Types > Dx (Check on) 

3. Select Single (on) mode: select Node 10 

4. [Apply] [Close] 

 

 

 
  

Model 2 

Model 1 

1 

2 

3 

3 

4 



 

 

3. Truss Analysis Structural Analysis I  

(Basic) 

3 - 22 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

▶그림 3-21 전처리/후처리 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 3.19 

Analysis Pre and Post 
Modes 

2.7 Perform Analysis 

 

Analyze both Model 1 and Model 2. 

  

Main Menu: Analysis / Perform Analysis 

 

 

midas Gen effectively manages the analysis model using Preprocessing Mode and 

Postprocessing Mode.  Postprocessing Mode preserves the analysis results without 

accidently tempering the model data.  The operation status (Pre or Post Modes) can be 

switched from the lock looking icons.   

 

 

 

Preprocessing Mode (in short Pre Mode) 

Pre Mode is used to enter or revise such data as geometry, member information, loadings, 

boundary conditions, etc. to construct an analysis model.  Upon completion of analysis, Pre 

Mode is automatically switched to Post Mode.  

 

Postprocessing Mode (in short Post Mode) 

Post Mode becomes activated after the analysis is completed.  If no analysis results exist, 

then the icon is displayed inactive.  Post Mode allows checking and analyzing the analysis 

results such as reactions, displacements, member forces, stresses, etc., and furthermore 

analysis/design report can be generated.  
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▶Fig. 3.20 

Reactions due to nodal 
load 

2.8 Check Analysis Results 

 

Compare the reactions of Model 1 (externally determinate due to the external nodal load) with 

the reactions of Model 2 (externally indeterminate).    

  

Main Menu: Results / Reactions / Reaction Forces/Moments... 

1. Load Cases / Combinations > ST: Nodal Load  

2. Components > FXYZ  

3. Type of Display > Values, Legend (Check on)   

4. Click [...] next to Values, Decimal Points: ‘3’, Exp. (Check off),  

Apply upon OK (Check on), [OK]  

5. Display Node Numbers (Toggle off)  

6. Main Menu: View / Display...,   Boundary tab: Support (Check off), [OK] 
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▶Fig. 3-20  

Reactions due to 
concentrated load 

 

 

 

 

 

 

 

 

 
 
 
 
 
 

▶Fig. 3-21  

Reactions due to  
pretension load 

 

In case of an internal pretension load, no reactions are observed in Model 1, an externally 

determinate structure.  The internal pretension load in Model 2 results in horizontal reactions 

(FX) due to the restraints in the X direction, which is an externally indeterminate structure. 

  

Main Menu: Results / Reactions / Reaction Forces/Moments... 

1. Load Cases / Combinations > ST: Erection Tolerance 

2. Components > FXYZ  

3. Type of Display > Values, Legend (Check on) 

4. [Apply]  
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▶Fig. 3.22 

Deformations due to 
nodal load 

02.8.2 변위 및 변형 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶그림 3.22 

절점하중에 의한 변형 

 

Check the deformations due to the nodal load.  DXZ represents √𝐷𝑋2 + 𝐷𝑍2.  Model 1 

(externally static determinate truss) exhibits larger displacements than Model 2 (externally 

indeterminate truss). 

  

Main Menu: Results / Deformations / Deformed Shape…  

1. Load Cases / Combinations > ST: Nodal Load  

2. Components > DXZ  

3. Type of Display > Undeformed, Values, Legend (Check on)   

4. Click [...] next to Values, Decimal Points: ‘1’, Exp., Apply upon OK (Check on) 

5. [OK]  
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▶그림 3-25  

절점하중에 의한 축력 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 3.23 

Axial forces due to  
nodal load 

 

Difference in axial forces due to the pretension load can be observed between the 2 Models 

for the reason outlined above.  

  

Main Menu: Results / Forces / Truss Forces... 

1. Load Cases / Combinations > ST: Nodal Load  

2. Force Filter > All 

3. Type of Display > Contour, Deform, Values, Legend (Check on) 

4. Output Section Location > Max 

5. Click [...] next to Values, Decimal Points: ‘1’, 

 Exp., Set Orientation, Apply upon OK (Check off) 

6. [OK]  

7. [Apply]  
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Only the step 1 can be 
done as the setting from 
the previous Load Case 
(Nodal Load) remains 
unchanged. 
 
 
 
 
 
 
 
 
 

▶Fig. 3.24 

Axial forces due to  
pretension load 

 

 

 

 

 

 

 

 
 
 
 
 
 
 
 

▶그림 3.24 

프리텐션 하중에 의한 

축력 

 

Since no reactions are present in Model 1 (externally determinate truss) due to the pretension 

load, no axial forces exist in the members connected to the supports.  

  

Main Menu: Results / Forces / Truss Forces 

1. Load Cases / Combinations > ST: Erection Tolerance 

2. Force Filter > All  

3. Type of Display > Contour, Deform, Values, Legend (Check on) 

4. Output Section Location > Max  

5. [Apply]  
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03.1.1 Model 1 

내적 1 차 부정정 

 

 

 

 

 

 

 

 

 

 

 

 

 

▶식 3.3 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

▶그림 3.25(a) 

 
 

 

 

▶그림 3.25(b) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

10.2 Model 2 :  

내적 1 차 외적 1 차 

부정정 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 3.25 (a) 

 
 
 

 

 

 

Model 1 is externally determinate, but internally indeterminate.  

 

Degree of external indeterminacy: 𝑚𝑒 = 𝑛 − 3 = 3 − 3 = 0 

Degree of internal indeterminacy: 𝑚𝑖 = (3 + 𝑠 + 𝑟) − 2𝑘 = (3 + 10 + 0) − 2 × 6 = 1  

 

As the degree of indeterminacy of Model 1 is 1, the method of consistent deformation can be 

used by assigning the BF member force as an unknown, 𝑋1.  
 

𝑓11𝑋1 + 𝐷1 = ∆1 
 

𝐷1 is the change in distance between BF due to a load without the presence of the member 

BF (in a statically determinate structure).  𝑓11𝑋1 represents the change in distance between 

B and F due to the member force, 𝑋1 in BF.  ∆1 is zero without any fabrication error, but  in 

this case 5 mm is assumed to have taken place. 

  

Fig. 3.25(a) shows the member forces,  {𝑛𝑖
1} resulting from a unit load applied to B and F in 

the state of BF member severed.  Fig 3.25(b) shows the member forces,  {𝑛𝑖} resulting from 

the nodal load in the state of BF member removed.  The fact that the BF member is absent, 

both cases are now statically determinate structures.  
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3. Manual Calculations 

 



 

 

3. Truss Analysis Structural Analysis I  

(Basic) 

3 - 29 

 
 
 

▶Fig. 3.25(b) 

 
 

▶그림 3.26 
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11f and 1D are now found using the unit load method. 

       
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1 387.334 kNX     

where, 1X  is the BF member force due to the loading and fabrication error.  

 

Model 2 is both externally and internally indeterminate.  The degree of overall indeterminacy 

is 2.    

 

Degree of external indeterminacy: 𝑚𝑒 = 𝑛 − 3 = 4 − 3 = 1 

Degree of internal indeterminacy: : 𝑚𝑖 = (3 + 𝑠 + 𝑟) − 2𝑘 = (3 + 10 + 0) − 2 × 6 = 1   

1X = 316.272 
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▶Fig. 3.26 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

 

 

 

 

 

 

 

 

Since Model 2 is a structure of 2 degrees of static indeterminacy, 2 equations can be 

formulated with an unknown, 𝑋1  for the BF member force and an unknown 𝑋2  for the 

horizontal reaction at Node D.  From Model 1, the unknown 𝑋2 is added.  The horizontal 

reaction at Node D is removed, and a unit load is applied at Node D.  The member forces 

{𝑛𝑖
2} then become as Fig. 3.26. 
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Using the values found from Model 1 and the above {𝑛𝑖
2}, the unit load method is applied to 

obtain the following results: 
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𝑋1 represents the BF member force, and 𝑋2 represents  the horizontal reaction at Node D.  

{
𝑋1

𝑋2
 } =  {

305.270 kN

−105.613 kN
 }  
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1. Find the member forces in the 3 trusses below.  The material and section properties are 

identical to those of the tutorial.   

 

100 kN 100 kN 100 kN 100 kN 100 kN

6@6 m = 36.0 m

8
.0

 m

100 kN 100 kN 100 kN 100 kN 100 kN

100 kN 100 kN 100 kN 100 kN 100 kN  

 

2. Find the member forces in the statically indeterminate truss below.  The truss is subject to 

a nodal load and a fabrication error as shown below.  The material and section properties 

are identical to those of the tutorial. 

 

180 kN

8
.0

 m

4@6 m = 24.0 m

 

4. Exercise 

 

Fabrication error 
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▶Photo 4.1  

Arch structures 
(a) Arch bridge   
(b) Arch structure 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 4.1  

Arch rise ratio = ℎ / 𝑙 
 
 

1.1 Concept for Arch Analysis  

 

The arch structural system generates large horizontal reactions at the end supports while 

resisting vertical loads.  With the presence of horizontal reactions, forces in the arch 

members are predominantly compression forces, which in turn reduce bending moments in 

the arch members.    

 

  

 

 

The ratio of the height (ℎ) to span (𝑙), ℎ/𝑙 is referred to as the rise ratio.  When the rise ratio 

is too small, the arch tends to spread out, thereby increasing the axial force in the arch 

members.  On the contrary, a large rise ratio improves the structural performance as the arch 

members resist external loads through axial forces in the arch members.  But a high arch 

required for the span may prove to be uneconomical.  The rise ratio of about 0.3 is commonly 

known to be structurally efficient and yet economical.    

 

 

 

 

 

 

 

1. Introduction 
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▶Fig. 4.2  

Arch structure 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 4.3  

Supports for lateral thrust 
in arch structures  
 
 

A masonry arch as shown in Fig. 4.2 is historically proven to be structurally stable.  This is 

because the structure is designed to resist only axial forces.  The arch structure shown is a 

half section, which is symmetrical about Point B.  If tensile stresses develop at the bottom 

part of the capstone at Point B, the arch will become unstable leading to collapse.  However, 

if the horizontal compression force, H, can cancel the tensile stresses resulting from the 

moment, M, then the arch is capable of resisting the loading.      

 

H

/ 2P

A

B

/ 2P

M

H

h

2

 

 

 

The horizontal reaction force, H, at the base Point A plays the role of preventing the arch from 

spreading out.  In practice, the reaction can be provided by the form of a buttress or a tension 

tie as shown in Fig. 4.3.  

 

     

 

 

 

 

Buttress 

Arch 

Tension tie 

Arch 

Capstone 
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▶Eq. 4.1 

 
 

The condition of equilibrium at the center of the arch at Point B is expressed below. 

 

2 2

P
M H h   

l
 

 

The left side of the equation represents the acting moment, and the right side represents the 

load resisting capability.  One can observe that the lateral reaction, 𝐻 and the height, ℎ 

need to increase in order to compensate for increases in the loading, P and the span 𝑙.  If 

the arch height, ℎ becomes zero, 𝐻 also becomes zero, hence becoming a simple beam.  

Similar to the fact that a large section is required to resist moment in a simple beam, the arch 

height, ℎ will need to increase in order for the arch structure to resist moment.  It is therefore 

advantageous to form the arch shape similar to the moment diagram shape of the structure.      
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▶그림 4.5 

해석모델 

 

 

 

 
 

 

 

 
 
 
 
 

▶Fig. 4.4 

Analysis model 
  
(a) Model 1 
 
 
 
 
 
 
 
 
(b) Model 2 
 
 
 
 
 
 
 
(c) Model 3 
 
 

2.1 Model Overview 

 

 

Analyze the following 3 arch structures of different rise ratios, ℎ/𝑙 of 1:4, 1:5 and 1:7, and 

compare the displacements and member forces of the 3 cases. 

 

          

1
2
.5

 m

100.0 kN / m

 

   

10
.0

 m

 

 

     

7.
14

3 
m

 

 

 

 Material: Steel Fe570 (Modulus of elasticity, E = 2.05108 kN/m2 ) 

 Section 

Arch rib: Box shape 1,000×1,000×20 mm 

Stiffening girder: Box shape 1,000×1,000×20 mm 

Hanger: I-Section ISWB550 

 Load: uniformly distributed load 100.0 kN/m

2. Tutorial 

 

Stiffening girder 

Hanger Arch rib 
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▶그림 4.7 

작업평면 설정 

 

 

 

 

 
 

 

 
 

 

 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 4.5 

Save file &  
set unit system 
 
 

2.2 Work Environment 

 

Open a New File and save. 

 

Main Menu:  / New Project...  

Main Menu:  / Save as...  

1. File name: ‘Arch’ and [Save]  

 
 

Set a unit system to kN & m.  

 

Main Menu: Tools / Unit System 

1. Length > m, Force (Mass) > kN (ton)  

2. [OK]  
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▶Fig. 4.6 

Set a work plane 
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The example models exist in the 2-D X-Z plane. 

 

Main Menu: Structure / Structure Type  

1. Structure Type > X-Z Plane  

2. [OK]  
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▶Fig. 4.7 

Define material 
 
 
 

 
Name is automatically 
assigned if the material is 
selected from DB.  
Name can be revised. 
 

 
Weight Density is used 
to automatically calculate 
the selfweight. 
 
 

 
OK button closes the 
dialog box.  If multiple 
materials are defined, 
use Apply button. 
 
 

2.3 Material & Section Properties 

 

Select IS(S), Fe570 for the material.  Select I-Section for the hangers, and define a built-up 

box section for the remainder. 

 

Main Menu: Properties / Material Properties 

1. [Add...] 

2. Elasticity Data > Type of Design > Steel  

3. Steel > Standard > IS(S), DB > Fe570, [OK] 
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02.3.2 단면 정의 
 

 

 

 

 
 

 

 
 

 

 
 

 
 

 

 
 

 

 
 

▶그림 4.9 

단면정의 

 

 

 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 4.8 

Define sections 
 
 

 

Define the sections to be used in the model. 

 

1. Properties dialog window: click Section tab. 

2. [Add...]  

3. Section ID: 1, Name: ‘Rib and Girder’  

4. Section definition method > User, Section shape list > Box  

5. H: ‘1’, B: ‘1’, tw: ‘0.02’, tf1: ‘0.02’, [Apply]  

6. Section ID: 2 

7. Section shape list > I-Section, Section definition method > DB, DB > IS  

8. Sect. Name > ISWB550, [OK]  

9. [Close]  
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▶그림 4.11 

아치리브 생성 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 4.9 

Arch Wizard 
 
 

2.4 Nodes & Elements Generation 

 

Create an arch rib with the rise ratio of 1:4 (Model 1) using Arch Wizard, which generates a 

series of straight beam elements in segments. 

 

Main Menu: Structure / Base Structures / Arch...  

1. Input/Edit tab > Type: Parabola1, Number of Segments: ‘10’  

2. Boundary Condition: None, Span(L): ‘50’, Height(H): ‘12.5’  

3. Material > 1: Fe570, Section > 1: Rib and Girder 

4. Insert tab > Insert Point: ‘0, 0, 0’  

5. Rotations > Alpha: ‘0’, Beta: ‘0’, Gamma: ‘0’, [OK]  

6. Front View, Auto Fitting (Toggle on) 
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▶Fig. 4.10 

Create arch rib 
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▶그림 4.11  

행어 생성 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 4.11 

Create hangers 
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Create hangers by extruding Node to Line Element using Extrude Elements. 

 

Main Menu: Node/Element / Extrude 

1. Shrink, Hidden, Display Node Numbers, Iso View (Toggle on) 

2. Select by Window (on) mode: Nodes 2-10 

3. Extrude Type > Node → Line Element 

4. Element Attribute > Element Type > Beam  

5. Material > 1: Fe570, Section > 2: ISWB550, Beta Angle > 90  

6. Generation Type > Project, Projection Type > Project on a line  

7. Base Line Definition > P1: ‘0, 0, 0’, P2: ‘50, 0, 0’  

8. Direction > Normal, [Apply]  

9. Auto Fitting (Toggle on) 

10. [Close] 
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▶그림 4.13 

Beta Angle 

 

 

 

 
 
 
 
 
 
 
 

▶Fig. 4.12 

Beta Angle 
 
 
 

 
Beta Angle refers to the 
orientation of z-axis of 
Truss, Beam or Column 
line elements in Element 
Coordinate System.  
 
Unless a section is 
symmetrical in both axes 
(like a circle or square 
section), the stiffness of the 
section changes with Beta 
Angle.  

 

 Beta Angle 

 
Beta Angle 90  ̊orients the hanger section web axis perpendicular to the span of the bridge.  

Refer to Create Elements in Online Manual for Beta Angle. 

 

  

Bata Angle: 0[Deg] Bata Angle: 90[Deg] 
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▶Fig. 4.13 

Input stiffening girder 
 
 

 

Create the stiffening girder between Node 1 and Node 11.  

 

Main Menu: Node/Element / Create Elements  

1. Shrink, Hidden (Toggle off), Front View (Toggle on) 

2. Element Type > General beam/Tapered beam  

3. Material > Name > 1: Fe570, Section > Name > 1: Rib and Girder  

4. Click the Nodal Connectivity field (which turns to green) 

5. Click Node 1 and Node 11 on the model view sequentially. 
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▶그림 4.15  

경계조건 입력 

 

 

 

 
 

 
 

 

 
 

 

 
 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 4.14 

Define support 
conditions 
 
 

2.5 Define Boundary Conditions 

 

The left support of Model 1 (Node 1) is assigned a pin support with Dx & Dz degrees of 

freedom restrained.  The right support (Node 11) is assigned a roller support with Dz degree 

of freedom restrained.  

 

Main Menu: Boundary / Define Supports  

1. Support Type > Dx, Dz (Check on)   

2. Select Single (on) mode: select Node 1  

3. [Apply]  

4. Support Type > Dx (Check off), Dz (Check on) 

5. Select Node 11 

6. [Apply]  
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▶Fig. 4.15 

Define hinge conditions  
at the ends of hangers 
 
 

 

Define hinges at the ends of each hanger (Beam End Release). 

 

Main Menu: Boundary / Beam End Release  

1. Display Node Numbers (Toggle off), Display Element Numbers (Toggle on) 

2. Select by Window (on) mode: drag a window from Element 19 to Element 11 (right 

to left).  No elements other than the hangers should be within the window.  Double-

click to complete the selection.      

3. General Types and Partial Fixity > [Pinned-Pinned]  

4. [Apply] [Close] 
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02.6.1 하중조건 정의 
 

 

 

 

 
 

 
 

 

 

▶그림 4.17 

하중조건 정의 

 

 

 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 4.16 

Define load case 
 
 

2.6 Define Loads 

    

 Define the load case (load type) first to which the uniformly distributed load will belong. 

 

Main Menu: Load / Static Loads / Static Load Cases 

1. Name: ‘Uniform’  

2. Type > User Defined Load (USER)  

3. [Add] [Close] 
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▶Fig. 4.17 

Input uniformly 
distributed load 
 
 

 

Input a uniformly distributed load, 100 kN/m on the stiffening girder.  

 

Main Menu: Load / Static Loads / Element Beam Load 

1. Load Case Name > Uniform, Options > Add  

2. Load Type > Uniform Loads, Direction > Global Z  

3. Value > Relative  

4. x1: ‘0’, w: ‘-100’, x2: ‘1’  

5. Select Girder (Elements 20 - 29), [Apply]  

6. [Close], Works Tree: right-click Element Beam Loads: 10 and Undisplay  
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02.6.3 요소 복제 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

▶그림 4.19  

요소복제 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 4.18 

Copy elements 
 
 

 

Copy Model 1 to create Model 2 and Model 3.  The loading and boundary conditions 

assigned to Model 1 are simultaneously copied.   

 

Main Menu: Node/Element / Translate Elements 

1. Mode > Copy 

2. Translation > Equal Distance > dx, dy, dz: ‘0, 0, -15’, Number of Times: ‘2’  

3. Copy Node Attributes, Copy Element Attributes (Check on) 

4. Display Element Numbers (Toggle off), Select All  

5. [Apply]  
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‘/’ Symbol is the division 
operator within the 
software.  
 
 
 
 
 
 
 
 
 
 

▶Fig. 4.19 

Revise models 
 
 

 

Change the heights of Model 2 and Model 3.  

 

Main Menu: Node/Element / Scale 

1. Display Node Numbers (Toggle on) 

2. Scale Factors > sfx: ‘1.0’, sfy: ‘1.0’, sfz: ‘4/5’  

3. Scale About > User: ‘25, 0, -15’  

4. Selection Type > By Selection 

5. Select by Windows (on) mode: select Nodes 22-30, [Apply]  

6. Scale Factors > sfx: ‘1.0’, sfy: ‘1.0’, sfz: ‘4/7’  

7. Scale About > User : ‘25, 0, -30’  

8. Selection Type > By Selection 

9. Select by Windows (on) mode: select Nodes 42-50, [Apply]  
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▶그림 4.21 

해석 완료 

 

 

 
 

 

 
 

 

 

 
 

 
 

 

 
 
 
 
 
 
 
 

▶Fig. 4.20 

Message for a 
successful run 
 
 
 
 
 
 
 
 
 

2.7 Perform Analysis 

 

Analyze all three models.  

 

Main Menu: Analysis / Perform Analysis  
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▶Fig. 4.21 

Deformation results 
 
 
 
 
 
 
 
 
 
 
 
 
 

2.8 Check Analysis Results 

 

 Check the deformations.  DXZ represents √𝐷𝑋2 + 𝐷𝑍2. The shallower the height of the 

arch becomes, the greater is the deflection.  When identical members are used, a reduction 

in height signifies a reduction in stiffness. 

 

Main Menu: Results / Deformations / Displacement Contour... 

1. Display Node Numbers (Toggle off) 

2. Load Cases / Combinations > ST: Uniform  

3. Components > DXZ  

4. Type of Display > Contour, Deform, Values, Legend (Check on) 

5. [Apply]  

6. Change the unit to mm from the Status Bar at the bottom of the screen. 
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02.8.2 축력 
 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

▶그림 4.23 

축력 결과 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 4.22 

Axial forces 
 
 

 

Check the axial forces due to the uniformly distributed load.  It can be observed that a lower 

arch height results in higher axial forces. 

 

Main Menu: Results / Forces / Beam Diagrams... 

1. Load Cases/Combinations > ST: Uniform  

2. Components > Fx  

3. Type of Display > Contour, Values, Legend (Check on), Deform (Check off) 

4. [Apply]  
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▶Fig. 4.23 

Moment results 
 
 

 

Check the bending moments.  The shallower the arch height becomes, the higher are the 

absolute bending moments in the stiffening girder and arch rib.  It can be also observe that 

lower arch heights result in reduction in bending moments where the arch rib and stiffening 

girder meet at each end.  

 

Main Menu: Results / Forces / Beam Diagrams... 

1. Change the unit to m from the Status Bar at the bottom of the screen. 

2. Components > My  

3. [Apply]  
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03.1.1  
Analysis concept 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 4.25 

Arch structures 
 
 
 
 
 
 
 
 

 

 
 

 

 
 

 

 

 

 
 

 

 
 

 

▶그림 4.26 

아치구조에서 횡방향 

반력의 지지 

 

 

 
 

 

 
 

 

 

 
 
 
 
 
 
 
 
 
▶Fig. 4.24 
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Though Model 1 is an arch structure, the overall behavior resembles that of a simple beam.  

The arch shape also resembles the moment diagram.  In a simple beam structure subject 

to a uniformly distributed load, one may design the beam with a larger section near the mid-

span, and progressively smaller sections towards the ends.  Similarly in an arch structure, 

the height at the mid-span is the highest, with the highest moment resistance, and the height 

gradually reduces to zero towards the ends.    

 

A structure like Model 1, bending moment can be resisted by a couple in the top chord (arch 

rib) and the bottom chord (stiffening girder).  That is, the tension in the bottom chord (or the 

compression in the top chord) multiplied by the height becomes the moment resistance at a 

corresponding location.  

 

 

 

 

3. Manual Calculations 

Hanger 

Arch Rib 

Stiffening girder 

20 24 

11 

12 
13 14 15 
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▶Table 4.1 

 
 
 

 

표 4.1 

 
 

 

 
 

 

The following table shows the element numbers with the corresponding forces, which will be 

explained below.  

 

Element No N (kN) V (kN) M (kN·m) 

24 2496.743 - -64.784 

5 -2509.24 - 105.495 

20 - 310.204 - 

11 433.461 - - 

12 505.076 - - 

13 501.131 - - 

14 500.052 - - 

15 500.150 - - 

 

A simple beam subject to a uniformly distributed load is now assumed in order to examine 

the relationship between the moment and the member forces at the mid-span.  The moment,

oM at the center Point C and the reaction, AR at Point A are calculated as,      

2 2100 50
31,250 kN m

8 8

100 50
2,500 kN

2 2


   


  

l

l

o

A

M

R




 

In the arch structure, the moment,
oM is resisted by a couple in the top and bottom chords.  

As such, the moment,
oM is divided by the height at the center.  

 

31,250
2,500 kN

12.5
  oM

N
h

 

 

The reason that this couple force (axial force) is different from the analysis values in Elements 

24 and 5 is that the arch rib (Element 5) and the stiffening girder (Element 24) are also subject 

to moments.  If these moments are hence considered, Element 24 will end up with the same 

axial force.  
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5 24 2,496.743 kN
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 oM M M
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h
 

 

Similarly the same axial force can be obtained if the axial force in the top chord Element 5 is 

converted into components in the horizontal direction.  

 

The reaction at Point A can be obtained by adding the shear force in Element 20 and the axial 

forces in the hangers (Elements 11-15), which then coincides with the simple beam reaction.  

 

15
20 11 12 13 14 2,500 kN

2
      A

N
R V N N N N  

 

From the above analysis, it can be observed that an arch structure resists external loads 

through axial forces, and its shape resembles the bending moment diagram, which resists 

acting loads.   
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Analyze the following 3 arch structures of varying stiffness (different sections), and compare 

the behaviors of the arches affected by the difference in stiffness.  Material properties are 

identical to those of the tutorial. 

Consider the Box sections in DB/User – user input 

 

1) Arch rib:    □ 2000×2000×20 mm 

   □ 1000×1000×20 mm 

   □ 1500×1500×20 mm 

2) Girder:    □ 1000×1000×20 mm 

   □ 2000×2000×20 mm  

   □ 1500×1500×20 mm 

3) Hanger:    ISWB 550 

 
  

 

(a) 

100.0 kN/m

6@10.0 m = 60.0 m
10

.0
 m

0.5H

2.0H

1.0H

 

(b) 

1.0H

2.0H

 

(c) 

1.5H

1.5H

 

 

4. Exercise 



 

 

5. Continuous Beam Analysis Structural Analysis I  

(Basic) 

5 - 2 

  



 

 

5. Continuous Beam Analysis Structural Analysis I 

(Basic) 

1 

5 - 1 

 

5. Continuous Beam 
Analysis  

Contents 

1   Introduction  

 

1.1 Concept of Continuous Beam Analysis 5-3 

 

 

2   Tutorial  

    

2.1 Model Overview 5-6 

2.2 Work Environment 5-7 

2.3 Material & Section Properties 5-9 

2.4 Generate Node & Element  5-10 

2.5 Define Boundary Conditions  5-12 

2.6 Define Loads   5-13 

2.7 Perform Analysis  5-14 

2.8 Check Analysis Result 5-19 

 

 

3   Manual Calculations  5-25 

 

4   Exercise  5-29 

  



 

 

5. Continuous Beam Analysis Structural Analysis I  

(Basic) 

5 - 2 

  



 

 

5. Continuous Beam Analysis Structural Analysis I 

(Basic) 

3 

5 - 3 

 
 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 

▶Photo 5.1  

Simple beam and 
continuous beam 
 
 
 
 
 
 
 
 
 
 
 
 
 

1.1 Concept for Continuous Beam 
Analysis 

 

 

A beam structure consisted of 2 or more connected spans is referred to as a continuous 

beam.  

 

  

 

 

In a continuous beam, the number of unknowns (reactions) is more than the number of 

force equilibrium conditions, hence becoming a statically indeterminate structure.  This 

leads to formulating additional conditions such as deformation compatibility conditions in 

order to find the unknowns. 

 

One of the characteristics of a continuous beam is that the behavior is affected by the 

flexural stiffness of adjacent members (spans).  Fig. 5.1 shows a 3-span continuous beam 

in which the moment distribution of Member BC depends on the flexural stiffness of the 

adjacent Members AB and CD.  

 

If Member BC were a simply supported beam, the moments at the ends B and C would 

have been zero.  Instead, the end moments, 𝑀𝐵and 𝑀𝐶  are non-zeros whose magnitudes 

depend on the flexural stiffness of Members AB and CD.  The stiffness of Member AB is 

greater than that of Member CD because of the rotational restraint at Point A.  The 

difference in stiffness leads to 𝑀𝐵whose magnitude is greater than 𝑀𝐶.  

  

1. Introduction 
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▶Fig. 5.1 

3-Span continuous 
beam  
 
 
 
 
 
 
 

 

A
B C

D

q

,   E I
,   E I

,   E I

A
M

B
M

C
M

D
M









21

8
q

B
M

C
M

B
M

C
M

 
 

 

Fig. 5.2 illustrates the beam stiffness, which varies with boundary conditions.  It is noted that 

the moment (𝑀1, 𝑀2, 𝑀3, 𝑀4) required to cause a unit rotational angle at the left end 

depends on the restraint condition at the right end.  Fig. 5.2(a) shows a fixed condition at 

the right end.  Fig. 5.2(b) is hinged at the right end.  Fig. 5.2(c) is imposed by the same unit 

rotational angle at the right end, hence resulting in a reverse curvature shape.  Fig. 5.2(d) is 

subject to an opposite unit rotational angle (-1) at the right end, which causes a 

symmetrically deformed shape.  The flexural stiffness of the 4 cases are (6𝐸𝐼/𝑙)in 5.2(c), 

(4𝐸𝐼/𝑙) in 5.2(a), (3𝐸𝐼/𝑙) in 5.2(b) and(2𝐸𝐼/𝑙)in 5.2(d) in descending order.   

 

Fig. 5.2(a) corresponds to Member AB in Fig. 5.1, and Fig. 5.2(b) corresponds to Member 

CD in Fig. 5.1. 
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01.1.2 해석개념 
 

 
 

 

 
 

 

 

 

 

 

 

 

 

▶사진 5.1  

단순보 및 연속보 

 
 

 

 
 
 

 

 

 

 

 

 

▶그림 5.1  

3구간 연속보 

 

 

 
 

 

 
 
 
 
 
 
 

 
 

▶Fig. 5.2 (a) 

 
 
 
 
 
 

▶Fig. 5.2 (b) 

 
 
 
 
 
 
 

▶Fig. 5.2 (c) 

 
 
 
 
 
 

▶Fig. 5.2 (d) 

 
 
 
 
 

 

 

1
M

2
M

3
M

4
M

1 

1 

1  1 

1  1  

0.5  

1

4


EI
M

2

3


EI
M

3

6


EI
M

4

2


EI
M

1
M

2
M

3
M

4
M

1
0.5 M

3
M

4
M

 
 

 

Though different analysis methods can be used to solve a statically indeterminate structure 

such as stiffness method, flexibility method, moment distribution method, finite element 

method, etc., the principle of Fig. 5.2 is used in all the methods.  Each method is 

appropriate for a specific type of problem.  In this chapter, the moment distribution method 

and flexibility method will be used for manual calculations.  The moment distribution 

method is relatively simple to use, which is also intuitive in understanding the characteristics 

of a simple structure. 
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2.1 Model Overview 

Analyze the following continuous and Gerber beams subject to a uniformly distributed load 

and a temperature load (temperature difference between top and bottom faces), and 

compare the reactions, displacements and member forces of the 3 cases.   

 

X

Z

9.8 kN / m 

T 5   ℃

5.0 m 5.0 m10.0 m

 

9.8 kN / m 

T 5   ℃

5.0 m 5.0 m5.0 m2.5 m 2.5 m

 

5.0 m 5.0 m2.5 m 7.5 m

9.8 kN / m 

T 5   ℃

 

 

 Material: Steel Fe570 

 Section: Box shape 300 ×200×12 mm  

 Load:  Uniformly distributed load 9.8 kN/m 

Temperature load: ΔT = 5 ℃  

(Difference in temperature between top & bottom) 

 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 5.3  

 
(a) Model 1 
3 Span continuous 
2 Degrees of 
indeterminacy 
 
 
 
 
 
 
 
(b) Model 2 
3 Span continuous 
determinate 
 
 
 
 
 
 
 
(c) Model 3 
3 Span continuous 
1 Degree of 
indeterminacy 
 
 
 
 
 
 
 
 

2. Tutorial 
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▶Fig 5.4  

Save file &  
set unit system 
 
 
 
 
 
 
 

2.2 Work Environment 

Open a New File and save. 
 

Main Menu:  / New Project...  

Main Menu:  / Save as...  

1. File name: ‘C-Beam’ and [Save] 

 
 

Set a unit system to kN & m.  
 

Main Menu: Tools / Unit System  

1. Length > m, Force (Mass) > kN (ton)  

2. [OK]  
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▶Fig. 5.5  

Set a work plane 
 

  
The example models exist in the 2-D X-Z plane. 
 

Main Menu: Structure / Structure Type  

1. Structure Type > X-Z Plane  

2. [OK]  
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If Material Properties are 
defined from DB, basic 
properties like modulus 
of elasticity, Poisson’s 
ratio, thermal coefficient 
and weight density are 
automatically assigned.  
 
 
 
 
▶Fig. 5.6  

Define material 
Define section 
 

2.3 Material & Section Properties 

Select IS(S), Fe570 for the material and select a box section.   
 

Main Menu: Properties > Material Properties  

1. [Add...], Type of Design > Steel  

2. Steel > Standard > IS(S), DB > Fe570, [OK] 

3. Properties dialog window: click Section tab.  

4. [Add...], Section shape list > Box  

5. Section definition method > DB, DB > IS 

6. Sect. Name > RHS 300x200x12  

7. [OK]  

8. [Close]  
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▶Fig. 5.7  

Create a node 
 

2.4 Nodes & Elements Generation 

Create a node first in order to create a continuous beam. 
 

Main Menu: Node/Element > Create Nodes  

1. Coordinates (x, y, z): ‘0, 0, 0’  

2. [Apply]  

3. Auto Fitting, Front View (Toggle on) 
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▶Fig. 5.8  

Create elements 
 

 

Create a continuous beam by extruding a node to line elements using Extrude Elements.  

 

Main Menu: Node/Element > Extrude  

1. Extrude Type > Node → Line Element  

2. Element Attribute > Element Type > Beam  

3. Material > 1: Fe570, Section > 1: RHS 300x200x12, Beta Angle: ‘0’  

4. Generation Type > Translate  

5. Translation > Unequal Distance  

6. Axis > x, Distance: ‘3@5/3, 8@10/8, 3@5/3’  

7. Select All  

8. [Apply]  
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▶Fig. 5.9  

Define support 
conditions 
 

2.5 Define Boundary Conditions  

Dx and Dz degrees of freedom are restrained for a pin support, and Dz degree of freedom 

is restrained for a roller support.  

 

Main Menu: Boundary / Define Supports 

1. Options > Add, Support Type > Dx, Dz (Check on) 

2. Display Node Numbers (Toggle on) 

3. Select Single (on) mode: select Node 4, [Apply]  

4. Support Type > Dx (Check off), Dz (Check on) 

  5. Select Single (on) mode: select Nodes 1, 12, 15, [Apply]  
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▶Fig. 5.10 

Define load cases 
 

2.6 Define Loads  

Define the load cases (load types) first to which the uniformly distributed load and the 

temperature load will belong.  

 

Main Menu: Load / Static Loads / Static Load Cases  

1. Name: ‘Uniform’  

2. Type > User Defined Load (USER), [Add]  

3. Name: ‘Temperature’  

4. Type > User Defined Load (USER), [Add]  

5. [Close]  
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▶Fig. 5.11 

Input uniformly  
distributed load 
 

 

 Input a uniformly distributed load, 9.8 kN/m on the continuous beam. 

 

Main Menu: Load / Static Loads / Element Beam Load 

1. Hidden, Display Node Numbers (Toggle off), Select All (Toggle on) 

2. Main Menu: View / Display... 

Load tab: Load Value (Check on), [OK]  

3. Load Case Name > Uniform  

4. Load Type > Uniform Loads  

5. Value > Relative x1: ‘0’, w: ‘-9.8’, x2: ‘1’  

6. [Apply]  
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▶Fig. 5.12 

Input temperature load 
 

 

Input a temperature difference (ΔT = 5 ℃) between the top and bottom faces of the beam. 

Thermal expansion coefficient in the material properties will be used to convert the 

temperature difference to stresses imposed on the beam. 

 

Main Menu: Load / Temp./Prestress / Temp. Gradient 

1. Select All (Toggle on) 

2. Load Case Name > Temperature 

3. Types > Beam  

4. Gradient > T2z-T1z: ‘5’  

5. [Apply]  
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▶Fig. 5.13  

Copy elements 
 

 

Copy Model 1 to create the Gerber beams, Model 2 and Model 3.  Apply Copy Node 

Attributes and Copy Element Attributes in order to simultaneously copy the loads and 

boundary conditions assigned to Model 1.    

 

Main Menu: Node/Element / Translate Elements 

1. Display (Toggle on) 

Boundary tab: Support (Check on), [OK] 

2. Select All (on)  

3. Mode > Copy  

4. Translation > Equal Distance  

5. dx, dy, dz: ‘0, 0, -5’, Number of Times: ‘2’  

6. Copy Node Attributes, Copy Element Attributes (Check on) 

7. [Apply]  
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▶Fig. 5.14 

Input Gerber beam pin 
conditions 
 
 
 

 
i-node and j-node are the 
first and last nodes 
respectively defining the 
corresponding element, 
which determines the 
element local x-axis.   
 
Check on Local Axis or 
Local Direction in 
Element tab in [Display] 
in order to see the 
element direction (i-node 
& j-node). 

 

Assign hinge conditions to the Gerber beam Models 2 and 3, by defining releases at the 

ends of the corresponding beam elements. 

 

Main Menu: Boundary / Beam End Release  

1. Display Element Numbers (Toggle on) 

2. Select Single (on) mode: select Elements 19, 23, 33  

3. General Types and Partial Fixity > [Fixed-Pinned]  

Check to see: i-Node > My, Mz (Check off), j-Node > My, Mz (Check on)  

4. [Apply]  
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▶Fig. 5.15 

Message for a 
successful run 
 

2.7 Perform Analysis 

Analyze all three models.  

 

Main Menu: Analysis / Perform Analysis  

1. Display Element Numbers (Toggle off) 

2. Check for successful completion in Message Window. 
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▶Fig. 5.16 

Reactions due to 
uniform load 
 
 

2.8 Check Analysis Results 

Compare the reactions due to the uniformly distributed load among the 3 Models.  Models 

1 and 2 are symmetrical, and the reactions are also symmetrical.  In Model 3, the reaction 

near the cantilever part shows a higher magnitude.   

 

Main Menu: Results / Reactions / Reaction Forces/Moments...  

1. Display (Toggle on) 

Boundary tab: Support (Check off), Beam End Release Symbol (Check on), [OK]  

2. Load Cases/Combinations > ST: Uniform 

3. Components > FXYZ  

4. Type of Display > Values, Legend (Check on), [Apply] 
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▶Fig. 5.17 

Reactions in table 
 

 

The reactions due to the uniformly distributed load will be checked in a table.  Structure 

models and loading input can be checked by comparing the sum of external load and the 

sum of reactions. 

 

In the current example, the total external load in the Z-axis direction in Global Coordinate 

System is 9.8 kN/m×20m×3 = 588kN, which matches the table value. 

 

Main Menu: Results / Result Tables / Reaction... 

1. Load Cases/Combinations > Uniform(ST) (Check on), Temperature(ST) (Check off) 

2. [OK]  
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▶Fig. 5.18 

Reactions due to 
temperature 
 

 

No reactions are generated due to the temperature load in Model 2 as it is a statically 

determinate structure, whereas reactions are present in Models 1 and 3 since they are 

statically indeterminate.    

 

Click Model View tab. 

Main Menu: Results / Reactions / Reaction Forces/Moments...  

1. Load Cases/Combinations > ST: Temperature 

2. Components > FXYZ  

3. Type of Display > Values, Legend (Check on) 

4. [Apply]  
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▶Fig. 5.19 

Displacements due to 
temperature 
 
 

 

Check the deformations due to the temperature load.  DXZ represents 2 2DX DZ .  

The continuous beam Model 1 exhibits the least displacements.  In the cases of Gerber 

beams, statically indeterminate Model 3 shows higher displacements than those of the 

statically determinate Model 2.  

 

Main Menu: Results / Deformations > Deformed Shape... 

1. Load Cases/Combinations > ST: Temperature  

2. Components > DXZ  

3. Type of Display > Undeformed, Legend (Check on), Values (Check off) 

4. [Apply]  
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▶Fig. 5.20 

Bending moment 
diagrams due to uniform 
load 
 
 

 

Check bending moments due to the distributed load.  

 

Main Menu: Results > Forces > Beam Diagrams...  

1. Load Cases/Combinations > ST: Uniform  

2. Components > My  

3. Display Options > Scale: ‘2.0’, No Fill  

4. Type of Display > Contour, Values, Legend (Check on), Deform (Check off) 

5. Display (Toggle on) 

Boundary tab: Support (Check on), [OK]  

6. [Apply]  

 

 

 

Bending moments in the center of the mid-span of Gerber Model 2 are smaller than those in 

the continuous beam Model 1.  But the negative moments at the interior supports in Gerber 

Model 2 are higher than those of Model 1.  Note that the sums of the positive and negative 

moments in both Models 1 and 2 are equal (68.8+53.7=91.9+30.6).  In the case of Model 3,  

Model 1 

Model 2 

Model 3 
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▶Fig. 5.21 

Moments due to 
temperature 
 
 
 

the support moment near the hinge is similar to that of Model 1, and the moment at the 

other interior support is similar to that of Model 1.  

Check bending moments due to the temperature load. 

 

As stated above for deformations due to the temperature, Gerber Model 2 exhibits the 

characteristic that the cantilever parts and the center simple beam behave independently.  

The fact that there are no restraints to the deformation due to the internal load, no member 

forces are generated in Model 2 due to the temperature change.  

 

Main Menu: Results > Forces > Beam Diagrams...  

1. Load Cases/Combinations > ST: Temperature  

2. [Apply]  
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▶Fig. 5.22 

Moment distribution 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Table 5.1 

Results from moment 
distribution method 

 

 
▶표 5.1  

모멘트 분배 

 

 

 

 

 

 

 
▶그림 5.28 

모멘트 분배법에 의한  결

과 

 

As Model 1 is symmetric about the mid-span, the moment distribution method can be used 

for the half structure.  Point A being a hinge (roller), the stiffness of Member AB 

becomes 3𝐸𝐼/𝑙. The rotational angles at Points B and C are symmetrical (equal magnitude 

and opposite direction), which results in the stiffness of Member BC equal to2𝐸𝐼/𝑙.  The 

member stiffness, distribution factors and fixed end moments can be expressed as follows:  

A DCB
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The moment at Point B can now be obtained through the moment distribution method.  

Moment distribution method Point A Point B 

Distribution factor 1.0 0.75 0.25 

Fixed end moment 0 30.625 -81.667 

Distributed unbalanced moment 0 38.282 12.761 

Carryover moment (factor=0.5) 0 0 0 

Final moment 0 68.907 -68.907 

Distributed unbalanced moments at Point B are: 

       
( ) 38.282BA BC BAM M D   

, 
( ) 12.761BA BC BCM M D   

 

Carryover moment is induced at the other end of the member in question (Fig.5.2(a)). 
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Center of symmetry 



 

 

5. Continuous Beam Analysis Structural Analysis I  

(Basic) 

5 - 26 

 

 

 

 
 
 
 
 
 
▶Fig. 5.23 

Moment distribution method 
 
 
 
 
 
 
 
 
▶Fig. 5.24 

Model 2 decomposition 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 5.25 

Model 2 moment calculation 
 

 

The fixed end moment at Point A is zero, as the fixed end moment at Point B is calculated 

reflecting the hinge status at Point A.  Carryover moments at Points A and B are zero since 

moment distribution is not required any further.   

 

.
A DCB

68.907

53.594

4

68.907

 

 

Model 2 is statically determinate, which can be analyzed as below.   

 

24.5 24.5
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▶Fig. 5.26 

Method of consistent 
deformation 
 

 

Model 3 is a statically indeterminate structure, which will be analyzed using the method of 

consistent deformation (or the unit load method) among other methods.  The moment at 

Point C, 𝑀𝐶  is defined as an unknown.  

 

 

 

 

(a) 

 

 

 

(b) 
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Fig. 5.26(a) shows an analysis model to which a hinge at Point C is assigned.  Analysis is 

then performed with the applied loading, and secondly with a unit moment applied at the 

hinged Point C.  With the introduction of the hinge at Point C, the structure becomes  

)(m

)(m
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▶Fig. 5.27 

Moment calculations by 
method of consistent 
deformation 

 

statically determinate, which can be solved by only force equilibrium.  Since the hinge 

actually does not exist, the following compatibility condition for the unknown, 𝑀𝐶  needs to 

be satisfied:  

 

    0cm M M     

 

𝜃(𝑚) represents the rotational angle at Point C subject to the applied unit moment.  

𝜃(𝑀)represents the rotational angle at Point C due to the applied loading.  The above 

equation signifies that the kink in the deformed shape cannot occur as the beam is 

continuous over Point C.  The unknown, 𝑀𝐶  can be now found using the method of 

consistent deformation.  
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▶그림 5.36 

연습문제  

Model 1 

 
 

 

 
 

 

 
 

 

Model 2 
 

 

 
 

 

 
 

 
Model 3 

 

 
 

 

 
 

 

 
 

 

Model 4 

 

 
 

 

 
 

 

 
 

 

 

 

 

 
 

 

 
 

 

 
 

 

 
 

 

 

 

 

The following 4 cases have the same spans and loadings, but with different structural 

systems, which are simple beam, Gerber beam, continuous beam and reinforced section 

over interior supports.  Find the moment diagrams of the 4 cases, and confirm that the 

positive moments progressively decrease and the negative moments progressively 

increase from a) through d).  
 

(a) 

2 m 2 m 2 m2 m12 m

Z

X

80 kN 80 kN20 kN/m

 

(b) 

2 m 2 m 2 m2 m8 m

80 kN 80 kN20 kN/m

2 m 2 m

 

(c) 

2 m 2 m 2 m2 m12 m

80 kN 80 kN20 kN/m

 

(d) 

2 m 2 m 2 m2 m8 m
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2 m 2 m

1I2I 2I
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▶그림 1.1  

단순보 

 

 

 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Photo 6.1  

Frame structures 
 
 
 
 
 

1.1 Concept for Frame Analysis 

 

Members rigidly connected (fixed joint or rigid joint) are referred to as a frame or rigid frame.  

Generally a column is rigidly connected to beam(s) forming a continuous structure.  

Members joined at a node can transfer bending moments, shear forces and axial forces.   

 

 
 

 

Frames can take many different forms and shapes from a simple portal frame to composite, 

rectangular, gable and concrete shear wall frames.   

 

Structural applications are also diverse such as regular shape frames like offices, schools, 

and hospitals, and irregular shape frames like temporary erection structures, plants, stadiums 

and gymnasiums. 

 

Concrete frame structures are also widely used such as bridges and shear walls with 

openings in building structures.  

  

1. Introduction 
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▶Fig. 6.1  

Frame structure types 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 6.2  

Frame deformation 
 

 

   
(a) (b) (c) 

   

(d) (e) (f) 

 

 

In a statically indeterminate frame structure subject to an external force such as shown in Fig. 

6.2, the angles formed by the members rigidly connected at nodes are assumed to remain 

unchanged after deformation.  In this case, all the members at the nodes remain 

perpendicular in the deformed shape.   

 

  

 

  

Fully fixed 
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▶Fig. 6.3  

Element Coordinate 
System (ECS) and 
displacements of a frame 
member  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
 

 

The structural concept for frames is not different from that of simple, cantilever and continuous 

beams.  Frame members are also line members like in continuous beams, but they are 

connected in 2 or 3 dimensions.  Each member of a frame structure retains its own Element 

Coordinate System (ECS).  Generally the x -axis direction is from i-Node to j-Node.  z -axis 

is perpendicular to x -axis. y -axis is determined by the right hand rule.  

 

 

,x u
,z  ,y 

i

j

X
Y

Z

 

 

 

The degree of static indeterminacy of a frame structure can be found in the same manner 

explained for truss structures.  Statically indeterminate frame structures can be also 

analyzed by the same methods used for truss analysis.  Reaction results follow the Global 

Coordinate System (GCS), and the member forces are generated in ECS.  The translational 

displacements in ECS 𝑥, 𝑦, 𝑧 directions are expressed as 𝑢, 𝑣, 𝑤 respectively.  𝜃𝑥 , 𝜃𝑦 , 𝜃𝑧   

are defined for the rotational displacements about 𝑥, 𝑦, 𝑧  axes respectively.  The 

deformation and sectional axes of a 2-D frame member on the GCS X-Z plane can be 

illustrated as Fig. 6.4.  

 

  



 

 

6. Frame Analysis 

6 - 6 

Structural Analysis I  

(Basic) 

 
 

 

 

 

▶Fig. 6.4  

2-D frame deformation and 
sectional axes 
(a) Deformation in ECS 
(b) Sectional axes 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 6.5  

Deformations and member 
forces due to external loads 
in a frame structure 
 
 
 
 
 

 

  

u



x

z

y
w

x



 



 

y

z

x

 

(a)     (b) 

 

If a loading in ECS z-direction is applied to a frame element, deformation,  will take place 

in the direction perpendicular to ECS x -axis.  The direction of bending moment becomes 

the direction of rotation about ECS y -axis as shown in Fig. 6.4 (b).  

 

Frame structures are capable of resisting vertical and lateral loads as shown in Fig. 6.5. 

 

  

(a) (b) 

  
(c) (d) 
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▶그림 6.8  

해석모델 

 
 

 

 
 

 
 

 

 
 

 

 
 

 

 
 

▶Fig. 6.6  

Analysis models 
(a) Model 1 
(a) Model 2 
 

2.1 Model Overview 

 Find the member forces and deformations of the following frame structures:  

 

 kN m 20

z

 kNP1 35

.  m4 5

 kN m 20

x .  m4 5 .  m4 5 .  m4 5

.
 m

4
5

.
 m

4
5

 kNP1 35  kNP1 35  kNP1 35

 

 

 

 Material 

Concrete: IS(RC) M40 (Modulus of elasticity, E = 3.1622×107 kN/m2) 

 Section 

Area: 5×10-4 m2 

Moment of inertia (Iyy): 6×10-3 m4 

 Load 

1. Distributed load applied at the top of beam: 20 kN/m 

2. Concentrated load, 35 kN applied in (+) X-direction at the top of each column 

 

 

  

2. Tutorial 

 

Model 1 Model 2 



 

 

6. Frame Analysis 

6 - 8 

Structural Analysis I  

(Basic) 

 
 

 
 
 
 
 
 

▶Fig. 6.7 

Analysis models  
 

 

All the members in Model 1 are rigidly connected, whereas hinges are introduced in the 

middle of the members in Model 2.  The member forces and deformations of the 2 models 

will be examined.  
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▶Fig. 6.8 

Save file &  
set unit system 
 
 

2.2 Work Environment 

Open a New File and save. 

 

Main Menu:  / New Project...  

Main Menu:  / Save As...  

1. File name: ‘Frame’ and [Save]  

 
 

Set a unit system to kN & m.  

 

Main Menu: Tools / Unit System  

1. Length > m, Force (Mass) > kN (ton)  

2. [OK]  
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▶Fig. 6.9  

(a) Set a work plane 
(b) Set User Coordinate 
System (UCS)  
 
 
 
 
 
 
 

 
UCS is more convenient 
for a structure with 
regular node and 
member spacing. 

 

The example models exist in the 2-D X-Z plane, which is defined as the x-y plane in User 

Coordinate System (UCS) for ease of modeling.  

 

Main Menu: Structure / Structure Type  

1. Structure Type > X-Z Plane  

2. [OK]  

 

Main Menu: Structure / UCS (User Coordinate System) / X-Z Plane 

1. Coordinates: ‘0, 0, 0’, Rotation Angle: ‘0’ and [OK]  
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Program automatically 
calculates section 
stiffness if section size is 
defined.  
 
For this tutorial, stiffness 
is directly entered.  
 
 
 
 
 
 
 

▶Fig. 6.10  

Define material 
Define section 
 

2.3 Material & Section Properties 

Define material and section for the structural members.  

 

Main Menu: Properties / Material Properties  

1. [Add...], Type of Design > Concrete  

2. Concrete > Standard > IS(RC), DB >M40 

3. [OK]  

4. Properties dialog window: click Section tab, [Add…], Value tab 

5. Section shape list > Solid Rectangle, Name: ‘Sec’  

6. H: ‘0.001’, B: ‘0.001’, Area: ‘5e+2’, Iyy: ‘6e-3’  

7. [OK], [Close]  
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Point Grid and Point Grid 
Snap are used to directly 
create nodes and elements 
on the modeling window.  
 
In the Point Grid Snap mode, 
placing the mouse on the 
modeling window prompts 
the coordinates displayed at 
the bottom of the screen. 
 
 
 
 
 

▶Fig. 6.11 

Create a column 
 

2.4 Nodes & Elements Generation 

Create nodes and beam elements simultaneously using User Coordinate System (UCS).  

 

Main Menu: Node/Element / Create Elements 

1. Display Node Numbers, Display Element Numbers, Auto Fitting, Front View 

     (Toggle on) 

  Main Menu: Structure / Grids / Define Point Grid… > Grid Spaces: 1, 1 and [OK] 

  Main Menu: View / Grids / Point Grid, View / Snap / Point (Toggle on) 

2. Element Type > General Beam/Tapered beam  

3. Material > 1: M40, Section > 1: Sec 

4. Click the Nodal Connectivity field (which turns to green)  

Model View: click (U: 0,0,0), (U: 0,9,0) coordinates sequentially 

 

 
 

 

U (0, 9, 0) 

U (0, 0, 0) 
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마우스 휠을 누른 상태

에서 드래그 하면 화면

에서 모델의 위치가 움

직이고 

마우스 휠을 한번 누른 

후에 휠을 돌리면 화면

을 확대/축소 할 수 있

다.확대/축소는 휠을 한

번 더 눌러준다. 

 

 
 

▶그림 6.14  

기둥, 보 생성 

 

 
 
 
 
 
 
 
 
 
 
 

▶Fig. 6.12  

Create column & beam  
 
 
 
 
 
 
 
 
 

 
Dragging the mouse on 
the screen with the 
wheel pressed on can 
pan the model.  
Pressing the mouse 
once and turning the 
wheel can zoom in/out 
the model.   
 

 

Referring to UCS coordinates at the bottom of the screen, click (U: 9, 0, 0), (U: 9, 9, 0) and (U: 

0, 9, 0), (U: 9, 9, 0) sequentially to create Elements 2 and 3.  In order to correctly snap the 

corresponding locations, ensure to keep Grid/Snap tab > Point Grid and Point Grid Snap 

toggled on. 
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▶Fig. 6.13  

Divide elements 
 

 

In order to define hinges in Model 2, divide all the elements into halves using Divide Elements. 

 

  Main Menu: Node/Element / Divide 

  1. Main Menu: View / Grids / Point Grid, Select All  

  2. Select Divide Elements > Element Type > Frame  

  3. Equal Distance  

  4. Number of Divisions x: ‘2’ 

  5. [Apply]  
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▶Fig. 6.14 

Define support 
conditions 
 
 
 
 
 
 
 

2.5 Define Boundary Conditions 

Fixed supports are assigned to the bottom of the columns.   

At the supports, 6 degrees of freedom (Dx, Dy, Dz, Rx, Ry, Rz) are symbolized by 6 triangular 

cells in a hexagon.  Dx to Rz are sequentially represented starting from the “12 o’clock” in 

the clockwise direction.  Green color in the triangular cells signifies restrained condition.  

Coordinate System is in GCS unless Nodal Coordinate System is defined. 

 

Main Menu: Boundary / Define Supports  

1. Support Type > Dx, Dz, Ry (Check on) 

2. Select Single (on) mode: select Nodes 1, 3 

3. [Apply]  
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▶Fig. 6.15 

Define load cases 
 

2.6 Define Loads 

Define the load cases (load types) first to which the uniformly distributed load and the 

concentrated loads will belong. 

 

Main Menu: Load / Static Loads / Static Load Cases  

1. Name: ‘Uniform’  

2. Type > User Defined Load (USER), [Add]  

3. Name: ‘Concentrated’  

4. Type > User Defined Load (USER), [Add]  

5. [Close]  
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02.6.1  
Define load cases 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 6.15  

Define load cases 
 

 
 
 
 
 
 

 
Once the elements are 
selected, the element 
numbers are listed at the 
top of Model View. 
 
 
 
 
 
 
 
 
 

▶Fig. 6.16  

Input uniformly  
distributed load 
 

 

 Input a uniformly distributed load on the beam. 

 

Main Menu: Load / Static Loads / Element Beam Loads 

1. Display (Toggle on) 

Load tab: Load Value (Check on), [OK] 

2. Select Single (Toggle on) mode: select Elements 3 and 6 

3. Load Case Name > Uniform 

4. Load Type > Uniform Loads  

5. Direction > Global Z  

6. Value > x1: ‘0’, w: ‘-20’, x2: ‘1’  

7. [Apply]  
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Once the nodes are 
selected, the node 
numbers are listed at the 
top of Model View. 
 
 
 
 

▶Fig. 6.17 

Apply nodal loads 
 

 

Apply concentrated loads at the top ends of the columns. 

 

  Main Menu: Load / Static Loads / Nodal Loads 

  1. Select Single (on) mode: select Nodes 2 and 4 

  2. Load Case Name > Concentrated 

  3. Options > Add  

  4. Nodal Loads > FX: ‘35’ 

  5. [Apply]  
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07.3 요소 복제 
 

 
 

 

 
Copy Node(Element) 

Attributes 는 원본 절점

(부재)에 입력된 데이터

를 동시에 복사하는 옵

션이다. 

 

 
 

 

 
 

▶그림 6.20  

Model 2 생성 

 

 
 
 
 
 
 

 
Copy Node (Element) 
Attributes will 
simultaneously copy the 
loads and boundary 
conditions assigned to 
Model 1. 
 
 
 
 
▶Fig. 6.18 

Create Model 2  
 

 

Copy the rigidly connected Model 1 to create Model 2 to the right.  Model2 will be 

subsequently assigned 3 hinges.  

 

Main Menu: Node/Element / Translate Elements 

1. Mode > Copy 

2. Translation > Equal Distance > dx, dy, dz: ‘12, 0, 0’  

3. Copy Node Attributes, Copy Element Attributes (Check on) 

4. Select All  

5. [Apply]  
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▶Fig. 6.19 

Input member hinge 
conditions 
 
 
 
 
 
 
 

 
[Pinned-Pinned], etc. buttons 
represent the boundary 
conditions at i-Node and j-
Node.  i-Node is the Node, 
which has a smaller Node 
number.   
 

 

Define internal Beam End Release in Model 2. 

 

Main Menu: Boundary / Beam End Release  

1. Display Node Numbers (Toggle off), Display Element Numbers (Toggle on) 

2. Select Single (on) mode: select Elements 7, 8, 9 

3. General Types and Partial Fixity > [Fixed-Pinned]  

4. [Apply]  
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▶Fig. 6.20 

Message for a 
successful run 
 

2.7 Perform Analysis 

Analyze the 2 Models. 

 

Main Menu: Analysis / Perform Analysis  

1. Check for successful completion in Message Window. 
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09.1 변위 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

▶그림 6.23  

중력방향에 의한 변형 

결과 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 6.21 

Deformed shapes due 
to the uniform load 
 

2.8 Check Analysis Results 

Check the deformed shapes of the 2 Models due to the gravity direction load (uniform load).  

Model 2 exhibits large deformation at the mid-span (hinge point) of the beam similar to the 

cantilever behavior.  

 

Main Menu: Results / Deformations / Deformed Shape… 

1. Display Node Numbers, Display Element Numbers (Toggle off) 

2. Load Cases/Combinations > ST: Uniform 

3. Components > DXYZ  

4. Type of Display > Undeformed (Check on) 

Click [...] next to Deform > Deformation Type: Real Deform, [OK]  
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▶Fig. 6.21  

Deformed shapes due 
to the uniform load 

 

 

 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
▶Fig. 6.22 

Deformed shapes due 
to lateral forces 

 

 

 

Deformed shapes due to the lateral concentrated loads will now be examined. 

Lateral deformation in Model 2 is a little more excessive from the hinge points at the mid-

height of the columns.  The lateral forces are transmitted to the lower half columns via shear 

forces from the hinge points acting as cantilevers.  The upper half columns offer limited 

resistance to lateral deformation.    

 

  1. Load Cases/Combinations > ST: Concentrated 

  2. Click [...] next to Deform > Deformation Scale Factor: ‘2.0’  

  3. [OK]  
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▶Fig. 6.23 

Shear Force diagrams 
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Find the shear forces due to the uniform load. 

   

The bending moments at the top ends of the columns in Model 2 are 202.5 kN·m due to the 

uniform load on the beam.  Each moment induces 45 (=202.5/4.5) kN at each column hinge 

point.  4.5 is the top half length of the columns above the hinge points.   

 

Main Menu: Results / Forces / Beam Diagrams... 

1. Load Cases/Combinations > ST: Uniform 

2. Components > Fz  

3. Display Option > Exact, Scale: ‘2’  

4. Type of Display > Contour, Deform (Check off), Values (Check on) 

5. [Apply]  
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▶Fig. 6.24 

Moment diagrams 
 
Moment diagrams 

 

Check bending moment diagrams due to the uniform load. 

Due to the hinge point at the mid-span of the beam in Model 2, the moment distribution 

resembles that of cantilever beams.  

 

Main Menu: Results / Forces / Beam Diagrams... 

1. Load Cases/Combinations > ST: Uniform 

2. Components > My  

3. Display Options > Scale: ‘1.0’  

4. Output Section Location > Min/Max  

5. [Apply]  
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▶그림 6.27  

횡력에 의한 휨모멘트

도 

 

 

 

 

 

 

 

 

 
 
 
 
 
▶Fig. 6.25 

Moment diagrams due 
to the lateral forces 

 

Check bending moments due to the lateral concentrated loads.  

 

Main Menu: Results / Forces / Beam Diagrams... 

1. Load Cases/Combinations > ST: Concentrated 

2. Components > My  

3. [Apply]  
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10.1 Model 1 계산 

횡력이 작용할 때 

 

 
 

 
 

 

 
 

 

 
 

 

 
 

 

 

 

 

▶그림 6.28  

 

 

 

 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 6.26 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Eq. 6.1 

 

 

<Case of acting lateral forces> 

Because the degree of indeterminacy of Model 1 is 3, the method of consistent deformation 

is not suitable for finding 3 unknowns by hand.  However, moment distribution can be an 

attractive method for hand calculation in which the symmetry is used and a degree of freedom 

is set as an unknown.  The number of unknowns can be then reduced to 1.  Fig. 6.26 (a) 

shows the inversely symmetrical deformed shape of Model 1 subjected to lateral forces.  If 

Points B and C are restrained against rotation under the acting lateral forces, the frame 

deforms as Fig. 6.26 (b), and fixed end moments, FM are induced.    

 

B C

DA

 

35 kN

FM FM

FM FM

l

l

( )a ( )b

35 kN 35 kN 35 kN

 

 

The fact that the real structure is not restrained against rotation at Points B and C, the 

restraints can be released using the moment distribution method.  The stiffness of the 

column and beam is calculated considering the inverse symmetry, which results in the 

distribution factors of 0.4 for the column and 0.6 for the beam as follows: 

 

   
4 6

 ,        BA BC

EI EI
k k 

l l
타단고정 타단역대칭  

                      

      

  

kBA (Fixed at Opposite end) = 
4𝐸𝐼

𝑙
 , kBc (Inverse Symmetry at Opposite end) = 

6𝐸𝐼

𝑙
 

3. Manual Calculations 
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▶Table 6.1 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Eq. 6.2 

 
 
 
 
 
 
 
 
 

▶Fig. 6.27 

 
 
 
 
 
 

 

The results from the moment distribution method are shown in Table 6.1 below, which 

coincide with the results from midas Gen.  

Moment distribution method Point A Point B 

Distribution factor 1.0 0.4 0.6 

Fixed end moment FM
 

FM
 

0 

Distributed unbalanced moment 0 -0.4
FM  -0.6

FM  

Carryover moment (factor=0.5) -0.2
FM  0 0 

Final moment 0.8
FM  0.6

FM  -0.6
FM  

 

Carryover moment is induced at the other end of the member in question (Fig. 5.2(a)) 

 

FM can be calculated from force equilibrium in the lateral direction.  

0.6 0.8 2.8
70 2


  

l l
F F FM M M

, 
225 kN m FM  

The results from the hand calculation coincide with the results from midas Gen.  

 

. FM0 6 . FM0 6

. FM0 8 . FM0 8
      

135 135

180 180
 

 

 

  



 

 
29 

6. Frame Analysis 

6 - 29 

Structural Analysis I  

(Basic) 

10.2 Model 1 계산 

중력하중이 작용할 때 

 

 

 
 

 

 
 

▶그림 6.31  

 

 
 

 

 
 

 

 
 

 

 
 

 

 

 

 

 
 

 

 
 

 

 

▶그림 6.32  

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 6.28 

 
 
 
 
 
 
 
 
 
 
▶Eq. 6.3 

 
 
 
 
 
 
 
 
 

▶Eq. 6.4 

 
 
 
 
 
▶Table 6.2 

 
 

<Case of acting vertical load> 

The vertical uniform load applied to Model 1 causes symmetrical deformation as shown in 

Fig. 6.28 (a).  The uniform load is now applied to Model 1 with Points B and C restrained 

against rotation, which then induces the fixed end moments, FM with the deformed shape as 

shown in Fig. 6.28 (b).  

B C

DA

l

( )b

 kN/m 20

( )a

FM FM

 
2

135 kN m
12

  
l

FM


 

The fact that the real structure is not restrained against rotation at Points B and C, the 

restraints can be released using the moment distribution method.  The stiffness of the 

column and beam is calculated considering the symmetry, which results in the distribution 

factors of 2/3 for the column and 1/3 for the beam as follows:     

            

   
4 2

 ,        BA BC

EI EI
k k 

l l
타단고정 타단대칭  

The results from the moment distribution method are shown in Table 6.2 below, which 

coincide with the results from midas Gen. 

Moment distribution method Point A Point B 

Distribution factor 1.0  2 / 3  1/ 3  

Fixed end moment 0  0  135  

Distributed unbalanced moment 0  90  45  

Carryover moment (factor=0.5) 45  0  0  

Final moment 45  90  90  

kBA (Fixed at Opposite end) = 
4𝐸𝐼

𝑙
 , kBc (Symmetry at Opposite end) = 

2𝐸𝐼

𝑙
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▶Fig. 6.29 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 6.30 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

90 90

45 45  

 

 

<Case of acting lateral forces> 

The number of reactions in Model 2 is 6, which requires 6 equations to solve, which can be 

formulated by 3 force equilibrium equations and zero moment condition at Points E, F and G.   

In fact Model 2 is a statically determinate structure.  
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▶Fig. 6.31  

 
 
 

 
 

▶그림 6.35 

 

 
 

 

 
 

 

 
 

 

 
 

 

 

 

 

 

<Case of acting vertical load> 
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Find the shear force, bending moment and axial force diagrams and the deformed shape of 

the frame below. 
 
 

1 65 kNP

3 m 5 m 5 m 3 m

3
 m

3
 m

X

Z

1.5 kN/m

 

 

 

 Material: Concrete strength M40 used in Tutorial 

 Section 

Shape: Solid Rectangle 

Size: B×H 0.5 × 0.5 m 

 Load 

Distributed load: 1.5 kN/m 

Nodal load: 65 kN 

4. Exercise 
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▶Photo 7.1  

Inclined supports 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 7.1 

(a) Inclined supports 
(b) Vertical supports 

 
 
 

 

 

 

 

 

 

 

 

▶그림 1.1  

단순보 

 
 

 

 
 

 

 

식 1.1  

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 7.2 

Force diagrams of 
structures in Fig. 7.1  
 
(a) Axial force diagrams 
 
 
 
 
 
 
 
 
(b) Shear force diagrams 
 
 
 
 
 
 
 
 
(c) Bending moment 
diagrams 

     1.1 Concept for Inclined Support 
Analysis 

A structure may be supported on inclined supports relative to Global Coordinate System 

(GCS).  It is important to recognize that deformation and member forces can vary depending 

on the orientation of supports.   

 

  

 

 

Fig. 7.1 shows identical structures, but the support conditions are slightly different.  Fig. 7.1 

(a) is restrained at Point C parallel to Member BC, whereas Fig. 7.1 (b) is vertically restrained 

at Point C. 
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1. Introduction 

 



 

 

7. Frame Analysis with Inclined Supports 

 

7 - 4 

Structural Analysis I  

(Basic) 

Fig. 7.2 shows the axial force, shear force and bending moment diagrams of the 2 structures, 

which illustrate significant differences in member forces depending on the support conditions.   

 

In the case of an inclined support, Fig. 7.2 (a) shows only a reaction at Point C with an axial 

force in Member BC.  However all the Members AB and BC are subject to bending moments 

with a reaction at Point A in the vertical support case as shown in Fig. 7.2 (b).  
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▶그림 7.5  

해석모델 

(a) 경사지점 

(b) 수직지점 

 

 

 

 
 

 

 
 

 

 
 

 

 
 
 
 
 
 
 

 

 

 
 
 
 
 
 
 
 
 
 

▶Fig. 7.3 

Analysis models 
 
(a) Inclined support 
 
 
 
 
 
 
 
 
 
 
 
 
 
(b) Vertical support 
 
 
 
 
 
 
 
 
 
 
 
 

2.1 Model Overview 

Compare the displacements, member forces and reactions between the 2 structures 
subjected to a uniformly distributed vertical load and a horizontal load of trapezoidal 
distribution.  Both frame structures are identical except for the support conditions.   
 

1 10.0 kN m 

1 10.0 kN m 

2 15.0  kN m 

4.0 m 4.0 m

4
.0

 m
2
.0

 m

45̊

 

1 10.0 kN m 

1 10.0  kN m 

2 15.0  kN m 

4.0 m 4.0 m

4
.0

 m
2

.0
 m

45̊

 

 

 Material: Fe570 

 Section: Box 1,000×1,000×10 mm 

 Load: 1. Distributed vertical load on horizontal member: 10.0 kN/m 

                                                                                                                     2. Trapezoidal horizontal load on vertical member: 10.0 - 15.0 kN/m  

2. Tutorial 
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▶Fig. 7.4 

Save file &  
set unit system 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

식 1.1  

 
 

2.2 Work Environment 

 

Open a New File and save. 

 

Main Menu:  / New Project...  

Main Menu: / Save As...  

1. File name: ‘Support’ and [Save]  

 
 

Set a unit system to kN & m.  

 

Main Menu: Tools / Unit System...  

1. Length > m, Force (Mass) > kN (ton)  

2. [OK]  
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▶Fig. 7.5 

Set a work plane 
 

 

 The example models exist in the 2-D X-Z plane. 

 

Main Menu: Structure / Structure Type  

1. Structure Type > X-Z Plane  

2. [OK]  

 

 

 

  

1 

2 



 

 

7. Frame Analysis with Inclined Supports 

 

7 - 8 

Structural Analysis I  

(Basic) 

 
 
 
 

 

 

 

 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 

▶Fig. 7.6 

Define material & section 
 

2.3 Material & Section Properties 

Define material and section for the structural members.  

 

Main Menu: Properties > Material Properties  

1. [Add...]  

2. Type of Design > Steel  

3. Steel > Standard >IS(S), DB > Fe570, [OK] 

4. Properties dialog window: click Section tab, [Add…] 

5. Name: ‘Sect’ 

6. Section shape list > Box, Section definition method > User  

7. H: ‘1’, B1=B2 : ‘1’, tw: ‘0.01’, tf1=tf2 : ‘0.01’, [OK], [Close] 
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▶그림 7.9  

절점 생성 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 7.7 

Create a node 
 

2.4 Nodes & Elements Generation 

Create a node in order to generate elements.  

  

Main Menu: Node/Element > Create Nodes  

1. Coordinates (x, y, z): ‘0, 0, 0’  

2. [Apply]  

3. Auto Fitting, Front View (Toggle on) 
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Beta Angle refers to the 
orientation of z-axis of 
Truss, Beam or Column 
line elements in Element 
Coordinate System.  
 
Unless a section is 
symmetrical in both axes 
(like a circle or square 
section), the stiffness of 
the section changes with 
Beta Angle. 
 
 
 
 
 
 

▶Fig. 7.8 

Create column 
 

 

Create the column in Model 1 by Extrude Elements, which extrudes Node to Line Element.  

 

Main Menu: Node/Element > Extrude  

1. Extrude Type > Node → Line Element  

2. Element Attribute > Element Type > Beam  

3. Material > 1: Fe570, Section > 1: Sect, Beta Angle: ‘180’  

4. Generation Type > Translate  

5. Translation > Equal Distance  

6. dx, dy, dz: ‘0, 0, 1’, Number of Times: ‘6’  

7. Select All  

8. [Apply]  
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▶Fig. 7.11  

수평부재 생성 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 7.9 

Create horizontal 
member 
 

 

Extrude the top node of the column to create the horizontal member.  

 

Main Menu: Node/Element > Extrude 

1. Display Node Numbers (Toggle on) 

2. Select Single (on) mode: select Node 7  

3. Extrude Type > Node → Line Element  

4. Element Attribute > Element Type > Beam  

5. Material > 1: Fe570, Section > 1: Sect, Beta Angle: ‘0’  

6. Generation Type > Translate  

7. Translation > Equal Distance  

8. dx, dy, dz: ‘1, 0, 0’, Number of Times: ‘4’  

9. [Apply]  
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▶Fig. 7.10 

Create sloped member 
 

 

Extrude the right end of the horizontal member to create the sloped member.  

 

Main Menu: Node/Element > Extrude 

1. Select Single (on) mode: select Node 11 

2. Extrude Type > Node → Line Element  

3. Element Attribute > Element Type > Beam  

4. Material > 1: Fe570, Section > 1: Sect, Beta Angle: ‘0’  

5. Generation Type > Translate  

6. Translation > Equal Distance  

7. dx, dy, dz: ‘4/6, 0, -4/6’, Number of Times: ‘6’ 

8. [Apply]  
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07.1 하중조건 정의 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
▶그림 7.14  

하중조건 정의 

 

 
 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 
 
 
 
 

▶Fig. 7.11 

Input support conditions  
 

2.5 Define Boundary Conditions 

All nodes in 3-D space retain 6 degrees of freedom (Dx, Dy, Dz, Rx, Ry, Rz).  In this tutorial, 

the degrees of freedom are permitted in the X-Z plane only, leaving only 3 degrees of freedom 

(Dx, Dz, Ry).  For a fixed condition, Dx, Dz, Ry degrees of freedom are restrained, and for a 

roller support, Dz degree of freedom is restrained.  

  

Main Menu: Boundary / Define Supports 

1. Options > Add, Support Type > Dx, Dz, Ry (Check on) 

2. Select Single (on) mode: select Node 1, [Apply]  

3. Support Type > Dx, Ry (Check off) 

4. Select Node 17, [Apply] 
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▶Fig. 7.12 

Define load cases 
 

2.6 Define Loads 

Define the load cases (load types) first to which the loadings will belong.  

 

Main Menu: Load / Static Loads / Static Load Cases 

1. Name: ‘Vertical’  

2. Type > User Defined Load (USER)  

3. [Add]  

4. Name: ‘Horizontal’  

5. Type > User Defined Load (USER)  

6. [Add], [Close]  
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07.2 등분포하중 입력 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
▶그림 7.15  

등분포하중 입력 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 7.13 

Input uniformly  
distributed load 
 

 

 Input a uniformly distributed load, 10 kN/m on the beam.  

 

Main Menu: Load / Static Loads / Element Beam Loads... 

1. Display (Toggle on) Load tab: Load Value (Check on) 

2. [OK]  

3. Load Case Name > Vertical  

4. Load Type > Uniform Loads  

5. Direction > Global Z 

6. Value > Relative 

7. x1: ‘0’, x2: ‘1’, w: ‘-10’  

8. Display Node Numbers (Toggle off), Display Element Numbers (Toggle on) 

9. Select Single (on) mode: select Elements 7, 8, 9, 10 

10. [Apply]  
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▶Fig. 7.14 

Input trapezoidal load on 
vertical member 
 

 

Input a trapezoidal load on the column, 10.0 - 15.0 kN/m distribution.  

 

Main Menu: Load / Static Loads / Line Beam Load 

1. Load Case Name > Horizontal  

2. Options > Add  

3. Load Type > Trapezoidal Loads  

4. Direction > Global X, Projection > No 

5. Value > Relative 

6. x1: ‘0’, x2: ‘1’, W1: ‘10’, W2: ‘15’  

7. Display Node Numbers (Toggle on), Display Element Numbers (Toggle off) 

8. Click the Nodes for Loading Line field (which turns to green), click Nodes 7 and 1 

sequentially in Model View 

9. [Close]  

10. Works Tree: right-click on Static Load case 2 [Horizontal] Line Beam Loads: 6 > 

Undisplay 
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▶Fig. 7.15 

Copy elements 
 

 

Copy Model 1 to create Model 2.  Loadings and support conditions assigned to Model 1 will 

be copied simultaneously.  

 

Main Menu: Node/Element / Translate Elements 

1. Hidden, Display Node Numbers (Toggle off) 

2. Mode > Copy 

3. Translation > Equal Distance > dx, dy, dz: ‘0, 0, -8’  

4. Copy Node Attributes, Copy Element Attributes (Check on) 

5. Select All (Toggle on) 

6. [Apply]  
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▶Fig. 7.16 

Change support 
condition 
 

 

Define Node Local Coordinate System (NLCS) to reflect the inclined support condition at the 

roller in Model 1.  NLCS is applied to the corresponding node only, which takes priority over 

GCS.  NLCS is used when displacements or support conditions exist in specific directions, 

which do not coincide with GCS.  Analysis results (displacements, reactions, etc.) can be 

also examined in NLCS.   

 

Main Menu: Boundary / Node Local Axis 

1. Display Node Numbers (Toggle on) 

2. Select Single (on) mode: click Node 17 

3. Options > Add/Replace  

4. Define Local Axis > Input Method > Angle  

5. about x: ‘0’, about y': ‘-45’, about z'': ‘0’  

6. [Apply]  

 

 

 

 

Model 1 

Model 2 

Node 17 

2 1 

3 

4-5 



 

 
19 

7. Frame Analysis with Inclined Supports 

7 - 19 

Structural Analysis I  

(Basic) 

 

 

 

 

 

 

 

 

 

 

 
 
 
 
 
 

▶Fig. 7.17 

Message for a 
successful run 
 

2.7 Perform Analysis 

 Analyze the 2 Models.  

 

Main Menu: Analysis / Perform Analysis  

1. Display Node Numbers (Toggle off) 

2. Check for successful completion in Message Window. 
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Local (if defined) is used 
for reactions in local 
coordinates if defined.   
 
 
 
 
 

▶Fig. 7.18 

Horizontal reaction due 
to vertical load 
 

2.8 Check Analysis Results 

Check the reactions due to the vertical load. 

Note that a horizontal reaction is observed at the left fixed support in Model 1. 

 

Main Menu: Results / Reactions / Reaction Forces/Moments... 

1. Load Cases / Combinations > ST: Vertical  

2. Components > FX, Local (if defined) (Check on) 

3. Type of Display > Values, Legend (Check on) 

4. [Apply]  
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▶Fig. 7.19 

Horizontal reactions due 
to horizontal load 
 

 

Check reactions due to the horizontal load.  

 

The fact that the inclined support in Model 1 resists the horizontal load, the horizontal reaction 

at the left fixed end in Model 1 is less than that in Model 2. 

 

Main Menu: Results / Reactions / Reaction Forces/Moments... 

1. Load Cases / Combinations > ST: Horizontal  

2. Components > FX  

3. Type of Display > Values, Legend (Check on) 

4. [Apply]  
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▶Fig. 7.21  

수평하중에 의한 

수평반력 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 7.20 

Deformations due to 
vertical load 
 

 

Check the deformed shapes of the 2 Models.  DXZ here means 2 2DX DZ .  

The vertical load causes Model 1 to deform to the left due to the presence of the inclined 

support.  Model 2 is observed to deform to the right.  

 

Main Menu: Results / Deformations / Deformed Shape... 

1. Load Cases / Combinations > ST: Vertical  

2. Components > DXZ (or DXYZ) 

3. Type of Display > Undeformed, Legend (Check on), Values (Check off)  

4. [Apply]  
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▶그림 7.23  

수평하중에 의한 변형도 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
▶Fig. 7.21 

Deformation due to 
horizontal load 
 

 

Check the deformed shapes of the 2 Models due to the horizontal load.  

 

Main Menu: Results / Deformations / Deformed Shape... 

1. Load Cases / Combinations > ST: Horizontal  

2. Components: DXYZ  

3. Type of Display > Undeformed, Legend (Check on), Values (Check off) 

4. [Apply]  
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▶Fig. 7.22 

Bending moments due 
to vertical load 
 

 

Check bending moments due to the vertical load.  

Due to the horizontal reaction of the inclined support in Model 1, large bending moment 

occurs in the column.  On the other hand, large moment is observed in the sloped member 

in Model 2 without the inclined support.  

 

Main Menu: Results / Forces / Beam Diagrams... 

1. Load Cases/Combinations > ST: Vertical  

2. Components > My  

3. Type of Display > Contour, Values, Legend (Check on), Deform (Check off) 

4. Click [...] next to Values 

5. MinMax Only, Abs Max (Check on) 

6. [OK]  
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▶Fig. 7.23 

Bending moments due 
to horizontal load 
 

 

Check bending moments due to the horizontal load.  

Though bending moments in the 2 Models share a similar pattern, Model 2 with the absence 

of the inclined support exhibits larger moment at the fixed end in comparison with Model 1.  

 

Main Menu: Results / Forces / Beam Diagrams... 

1. Load Cases/Combinations > ST: Horizontal  

2. Components > My  

3. Type of Display > Contour, Values, Legend (Check on), Deform (Check off) 

4. Click [...] next to Values 

5. MinMax Only, Abs Max (Check on) 

6. [OK]  
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▶Fig. 7.24 

Model 1 
 

 

The method of consistent deformation can be used by defining the reaction in the slope 

direction at Point D in Model 1 as an unknown.  
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09.3 휨모멘트 확인 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 
 
▶그림 7.25  

수평하중에 의한 

휨모멘트도 

 

 

 

 

 
 

 
 

 

 

 

 

 
 

 

 
 

 

 
 

 

 
 

 

 

 

▶그림 7.27  

Model 1 계산결과 

(Vertial + Horizontal) 

 

 

 
프로그램에서는 

Component :  

FXYZ(on) 
Local(off) 

에서 확인할 수 있다. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 
▶Fig. 7.25 

Model 1 calculation 
results 
 

 

The displacement at Point D due to a unit load applied in the direction of Member CD is 

defined as f in the state of the support restraint released at Point D.  The displacement at 

Point D in the direction of Member CD due to the member forces on Members AB and BC is 

now defined as D .  From this, a compatibility equation can be derived.   

 

0f X D    

where, 

  

 

     

 

 

2

22

2 3

2

0

6 4

0 0

0

6

0

4

0

1

1 1 1 4
   10 1

42 2

   166.667

1

1 1 15 5
   10 290 75

2 362

1 4
      1 80 40 5

42

   5045.914

f m x dx
EI

x
x dx dx

EI EI

EI

D m x M x dx
EI

x x x x dx
EI

x
x x dx

EI

E



    
       

    





  
       

  

  
      

  





 







l

l

30.225

I

D
X

f
   

 

Accordingly, the reaction at Point D becomes 30.225 kN, the direction of which is upward and 

opposite to the direction of the unit load.  
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▶Fig. 7.26 

Model 2 
 

 

The method of consistent deformation can be now used for Model 2 by defining the vertical 

reaction at Point D as an unknown.  Releasing the vertical support restraint at Point D and 

applying a unit load in the reaction direction results in the moment, ( )m x .  Applying the loads 

on Members AB and BC in the released condition results in a moment distribution, ( )M x

as shown in Fig. 7.26. 
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10.2 Model2 수계산 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
▶그림 7.29  

Model 2 계산결과 

(Vertial + Horizontal) 

 

 
 

 
프로그램에서는 

Component :  

FXYZ(on) 
Local(off) 

에서 확인할 수 있다. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 
 

▶Fig 7.27 

Model 2 calculation 
results 
 

The vertical displacement, f at Point D is caused by a unit load.  The vertical displacement, 

D at Point D is caused by the loads on Members AB and BC.  The following compatibility 

equation can be derived:   

 

0f X D    

where, 
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Hence the reaction at Point D becomes 13.8893 kN (upward). 
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Compare the member forces, displacements and reactions among the 3 frames of different 

column slopes below.  Material and section are identical to those in Tutorial.  

 

(a) 

6.0 m 6.0 m8.0 m

10 kN/m

6
.0

 m

 

(b) 6.
0
 m

60̊ 60̊

6.0 m 6.0 m8.0 m

10 kN/m

 

(c) 

30̊ 30̊

6.0 m

6.0 m 6.0 m8.0 m

10 kN/m
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▶Fig. 8.1  

Elastic boundary 
element examples 
(a) Boundary condition 
for Point Spring Support  
 
 
 

 

 

 
 
 
 
 
 
 
(b) Surface Spring 
Supports  
 
 

 

 

 

 

 

 

 

 

 

 

 

 

식 1.1  

 

 

1.1 Concept for Springs Analysis  

An elastic boundary element or a spring is used when the stiffness of a contiguous structure 

or ground at the boundary of a model needs to be reflected.  It is also used when elements 

(truss, plane stress, plate element, etc.) need to be connected with the absence of certain 

degrees of freedom.  

For a given node, springs can be specified for 6 degrees of freedom (3 translational and 3 

rotational) in Global Coordinate System (GCS).  Force per unit length is specified for a 

translational elastic component, and a moment unit per radian is specified for a rotational 

elastic component.   
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▶Table 8.1 

Representative moduli 
of subgrade reaction 

 

A translational elastic boundary element is appropriately used to represent ground stiffness 

at the bottom of a column or a pile at the lower part of a structure (substructure).  Modulus 

of subgrade reaction multiplied by the tributary area of the corresponding node is used to 

model the ground.  It should be noted that the ground can only resist compression, not 

tension.  

 

midas Gen provides the Surface Spring Supports function to readily represent the boundary 

condition of a surface in contact with soils.  Such boundary condition is specified in Model > 

Boundaries > Surface Spring Supports.  Once relevant nodes are selected, and the 

modulus of subgrade reaction parameter is specified, midas Gen automatically calculates 

the spring stiffness of the selected nodes based on the effective area of each node.  If the 

analysis needs to reflect the compression-only resistance of the ground, then Elastic Link 

(Compression only) needs to be specified.    

 

Ground type Modulus of subgrade reaction (kN/㎥ ) 

Soft clay 12,000~24,000 

Medium stiff clay 24,000~48,000 

Stiff clay 48,000~112,000 

Loose sand 4,800~16,000 

Medium dense sand 9,600~80,000 

Silty medium dense sand 24,000~48,000 

Clayey gravel 48,000~96,000 

Clayey medium dense sand 32,000~80,000 

Dense sand 64,000~130,000 

Very dense sand 80,000~190,000 

Silty gravel 80,000~190,000 

 

[Table 8.1]  

summarizes moduli of subgrade reaction for soils, which are typically encountered in practice.  

It is recommended that both maximum and minimum values be used separately, and 

conservative values with discretion be implemented for design. 
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The axial stiffness of spring supports for columns or piles can be calculated by EA/H, where 

E is the modulus of elasticity for columns or piles, A is effective cross-sectional area, and H 

is effective length. 

 

Rotational spring components are used to represent the rotational stiffness of contiguous 

boundaries of the structure in question.  If the contiguous boundary is a column, the stiffness 

is calculated by αEI/H, where α is a rotational stiffness component coefficient, I is effective 

moment of inertia, and H is the effective length of the column. 

 

Generally, boundary springs at a node are entered in the direction of each D.O.F.  For more 

accurate analysis, however, additional coupled stiffness associated with other degrees of 

freedom needs to be considered.  That is, springs representing coupled stiffness may 

become necessary to reflect rotational displacements accompanied by translational 

displacements.  For instance, it may be necessary to model pile foundation as boundary 

spring supports in which case more accurate analysis could be performed by introducing 

coupled stiffness in addition to the stiffness in each direction. 

 

Boundary springs specified at a node, in General, follow the GCS unless an NCS is specified 

in which case they are defined relative to the NCS. 

 

Subsequent to formulating the stiffness in the analysis stage, singular errors are likely to 

occur when stiffness components in certain degrees of freedom are deficient.  If the 

rotational stiffness components are required to avoid such singular errors, it is recommended 

that the values from 0.0001 to 0.001 be used.  The range of the values may vary somewhat 

depending on the unit system used.  To avoid such singular errors, midas Gen and midas 

Civil, thus provides a function that automatically assigns stiffness values, which are 

insignificant to affect the analysis results. 
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▶Fig. 8.2 

Continuous beam with a 
spring support 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

A spring is a support, which can accompany deformation.  Fig. 8.2 shows a 2- span 

continuous beam supported by a spring at the midpoint B.  The structure can be considered 

as a simple beam subjected to an upward force, Q , which exerts on the spring support.  
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The deflection of the above simple beam with a span of 2/𝑙, which is subjected to a uniformly 

distributed load, 𝑞 and a concentrated load, Q , is the same as the change in length of the 

spring.  The following governing equation can be written:  
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▶Fig. 8.3 

Relationship between 
the ratio of the flexural 
stiffness of the beam 

(𝐸𝐼/𝑙) to the spring 
stiffness (𝑘)  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 8.4 

Distribution of the spring 
stiffness (horizontal axis) 
and the spring 
deformation 
 
 
 
 
 
 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

 

Fig. 8.3 shows the relationship between the ratio of the flexural stiffness of the beam (𝐸𝐼/𝑙) 

to the spring stiffness (𝑘) (horizontal axis) and the reaction ratio (vertical axis).  The reaction 

ratio is the spring reaction relative to the reaction caused by a vertical support at Point B.  

Since the reaction at the midpoint in a 2-span continuous beam is 5𝑞(2/𝑙)/8, the spring 

reaction will always be a fraction of the hard support reaction.   
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Fig. 8.4 shows the distribution of the spring stiffness (horizontal axis) and the spring 

deformation divided by the span length (vertical axis).   
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It can be observed from Fig. 8.3 and Fig. 8.4 that the spring reaction increases with the 

increase in the spring stiffness, but the spring deformation decreases.  When the spring 

stiffness ratio exceeds 10, the spring deformation becomes negligible exhibiting the behavior 

similar to that of the hard support condition.  It can be also observed that a large transition 

takes place when the stiffness ratio is in the range of 0.1 - 1.0.  
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▶Fig. 8.5 

Analysis models 
 
Model 1,2,3:  
Spring connections 
 
 
 
 
 
 
 
Model 4:  
Internal hinge 
connection 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
 

 

 
 

 

 
 
 
 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

 

▶표 8.2   

스프링 계수 

 

 

 

 

 

 

 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

 

2.1 Model Overview 

Compare the reactions, displacements and member forces between the models, which vary 

in support conditions and spring stiffness.  

 

5.0 m 5.0 m

1
P 100.0 kN

1
k

2
k

3
k

 

 

 

5.0 m 5.0 m
 

 

 Material 

Steel: Fe440            

Modulus of elasticity (E): 2.05 ×108 kN/m2 

 Section 

Cross sectional area: 1.0×10-2 m2 

Moment of inertia (Iyy): 8.333×10-4 m4 

 Load 

Nodal concentrated load: 100.0 kN 

 Spring constants 

Type k1  (kN · m/radian) k2  (kN /m) k3  (kN /m) 

Model 1 1,000,000 10 100,000 

Model 2 100 100,000 100,000 

Model 3 1,000,000 100,000 100,000 

2. Tutorial 
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▶Fig. 8.6 

Save file &  
set unit system 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
 

 

 
 

 

 
 

 

 
 

2.2 Work Environment 

Open a New File and save. 

 

Main Menu:  / New Project...  

Main Menu:  / Save As...  

1. File name: ‘Support’ and [Save]  

 

Set a unit system.  

 

Main Menu: Tools / Unit System...  

1. Length > mm, Force (Mass) > N (kg)  

2. [OK]  
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▶그림 8.7 

작업평면 설정 

 

 
 
 
 
 
 
 
 
 
 
▶Fig. 8.7 

Set a work plane 
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The example models exist in the 2-D X-Z plane. 

 

Main Menu: Structure / Structure Type  

1. Structure Type > X-Z Plane  

2. [OK]  

 

 

 

  

1 

2 



 

 

8. Springs Analysis Structural Analysis I  

(Basic) 

8 - 12 

 
 
 
 
 
 
 

 

 

 

 

 

 

 
 

 

 
 

 

 
 
 
 
 
 

▶Fig. 8.8 

Define material & 
section 
 
 
 
 

2.3 Material & Section Properties 

Define material and section for the structural members. 

 

Main Menu: Properties / Material Properties  

1. [Add...], Type of Design > Steel  

2. Steel > Standard > IS(S), DB > Fe440 

3. [OK]  

4. Properties dialog window: click Section tab, [Add…] 

5. Value tab, Name: ‘Sec’  

6. Section shape list > I-Section  

7. Section Properties > Area: ‘1e+4’, Iyy: ‘8.333e+8’  

8. [OK], [Close]  
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▶Fig. 8.9 

절점 생성 

 
 

 

 

 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 8.9  

Create a node 
 
 

 
When Auto Fitting is 
toggled on, the model fits 
into the full screen, which 
automatically controls 
Zoom Size in real time. 
 

2.4 Nodes & Elements generation 

Change the units to m, kN.  Create a node in order to generate beam elements. 

 

Main Menu: Tools / Unit System > check on m, kN  

Main Menu: Node/Element / Create Nodes  

1. Coordinates (x, y, z): ‘0, 0, 0’  

2. [Apply]  

3. Auto Fitting, Front View (Toggle on) 

 

 

 

 

 

 

 

1 

2 

3 

3 



 

 

8. Springs Analysis Structural Analysis I  

(Basic) 

8 - 14 

 
 
 
 
 
 

 

 

 

 

 

 

 

 

 
 

 

 
 

 
 
 

▶Fig. 8.10 

Create beam elements 
 
 
 
 

 

Create the left side beam of Model 1 using Extrude Elements, which extrudes Node to Line 

Element.  

 

Main Menu: Node/Element > Extrude  

  1. Extrude Type > Node → Line Element  

2. Element Attribute > Element Type > Beam   

3. Material > 1: Fe440, Section > 1: Sec, Beta Angle: ‘0’  

4. Generation Type > Translate  

5. Translation > Equal Distance  

6. dx, dy, dz: ‘1, 0, 0’, Number of Times: ‘5’  

7. Select All  

8. [Apply]  
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▶그림 8.11 

보요소 복제 

 
 

 

 

 
 
 
 
 
 

 

 

 

 

 
 
 
 
 
 

▶Fig. 8.11 

Copy beam elements 
Create beam elements 
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Copy the left side beam elements of Model 1 to create the right side beam elements.  

 

Main Menu: Node/Element / Translate Elements 

1. Mode > Copy 

2. Translation > Equal Distance > dx, dy, dz: ‘5, 0, -0.1’  

3. Number of Times: ‘1’  

4. Select All  

5. [Apply]  
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▶Fig. 8.12 

Input support conditions 
 
 
 
 

2.5 Define Boundary Conditions 

Define boundary conditions at each end of the beams.  

 

Main Menu: Boundary / Define Supports  

1. Display Node Numbers (Toggle on) 

2. Support Type > Dx, Dz (Check on) 

3. Select Single (on) mode: select Node 1 

4. [Apply]  

5. Dz (Check off), Dx, Ry (Check on) 

6. Select Single (on) mode: select Node 12 

7. [Apply]  
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▶Fig. 8.12 

Input support conditions 
 
 
 

 

 
 
 
 
 
 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 8.13 

Input elastic support 
conditions 

 

Use Point Spring Supports to input the elastic support condition for the beams.  

Unlike Supports, which restrain the nodal degrees of freedom, Point Spring Supports are 

associated with boundary elements (springs) having elastic support stiffness for each degree 

of freedom.  The springs permit deformation based on the stiffness, and the member forces 

in the elastic boundary elements are generated in the form of reactions.   

 

Main Menu: Boundary / Point Spring Supports 

1. Point Spring (Local Direction) > SRy: ‘1,000,000’  

2. Select Single (on) mode: select Node 1 

3. [Apply]  

4. SDz: ‘100,000’, others: ‘0’  

5. Select Single (on) mode: select Node 12 

6. [Apply]  
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▶Fig. 8.14  

Define load case 
 
 
 
 

2.6 Define Loads 

Define the load case (load type) first to which the loading will belong. 

 

Main Menu: Load / Static Loads / Static Load Cases  

1. Name: ‘Nodal load’  

2. Type > User Defined Load (USER)  

3. [Add]  

4. [Close]  
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▶Fig. 8.15 

Input nodal load 
 
 
 
 

 

Input a concentrated load, 100 kN at Node 6.  

 

Main Menu: Load / Static Loads / Nodal Loads 

1. Display (Toggle on), Load tab: Load Value (Check on), [OK] 

2. Load Case Name > ‘Nodal load’  

3. Options > Add  

4. Nodal Loads > FZ: ‘-100’  

5. Select Single (on) mode: select Node 6 

6. [Apply]  
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▶Fig. 8.16 

Copy elements 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Copy Model 1 to create Models 2-4.  Nodal loading and support conditions assigned to 

Model 1 will be copied simultaneously. 

 

Main Menu: Node/Element / Translate Elements 

1. Mode > Copy 

2. Translation > Equal Distance > dx, dy, dz: ‘0, 0, -2’, Number of Times: ‘3’  

3. Copy Node Attributes, Copy Element Attributes (Check on) 

4. Select All  

5. [Apply]  
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▶그림 8.17 

Model 4 좌표 수정 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 

▶Fig. 8.17 

Revise Model 4 
coordinates 
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Move the right side nodes of Model 4 in the Z direction by 0.1 m to align with the left side to 

make the entire span continuous.  The overlapped nodes in the center will be merged using 

Merge Nodes (i.e., one node will be deleted). 

 

Main Menu: Node/Element / Translate Elements 

1. Mode > Move 

2. Translation > Equal Distance > dx, dy, dz: ‘0, 0, -0.1’  

3. Select Window (Toggle on), select Nodes 43-48 

4. [Apply]  

 

Main Menu: Node/Element / Merge Nodes 

5. Merge > All, Tolerance: ‘0.001’  

  Remove Merge Nodes (Check on) 

  [Apply]  
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▶Fig. 8.18 

Revise boundary 
conditions 
 
 
 
 

 

Revise the boundary conditions at both ends of Model 4 to a fixed condition.  

 

Main Menu: Boundary / Define Supports  

1. Options > Replace  

2. Support Type > Dx, Dz, Ry (Check on) 

3. Select Single (on) mode: select Nodes 37, 48 

4. [Apply]  
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▶그림 8.19 

스프링조건 수정 

 

 

 

 

 
 

 

 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 

▶Fig. 8.19 

Revise spring conditions 
 
 
 

 

Delete the elastic support conditions in Model 4, and revise the stiffness of elastic support in 

Model 2.  

 

Main Menu: Boundary / Point Spring Supports 

1. Options > Delete  

2. Select Single (on) mode: select Nodes 37, 48 

3. [Apply]  

5. Options > Replace  

6. SRy: ‘100’, others: ‘0’ 

7. Select Single (on) mode: select Node 13 

8. [Apply]  
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▶Fig. 8.20 

Input elastic link 
elements 
 

 

Input an elastic link at the gap between the left and right sides of the beams in each Model 1, 

2 & 3.  Elastic link elements are specified in Element Coordinate System.   

 

Main Menu: Boundary / Elastic Link… 

  1. Options > Add  

2. Elastic Link Data > Type > General, SDx: ‘100000’, others: ‘0’  

3. Click the 2 Nodes entry field (which turns to green), click Nodes 6 and 7 on the model 

view sequentially. 

4. Elastic Link Data > Type > General, SDx: ‘100,000’, others: ‘0’  

5. Click the 2 Nodes entry field (which turns to green), click Nodes 18 and 19 on the model 

view sequentially.  Continue clicking Nodes 30 and 31 sequentially. 

6. Display Node Numbers (Toggle off) 
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▶Fig. 8.21 

Input internal hinge 

 

Input an internal hinge in the center of Model 4. 

 

Main Menu: Boundary / Beam End Release 

1. Display Element Numbers (Toggle on) 

2. Select Single (on) mode: select Element 35 

3. General Types and Partial Fixity > j-Node > My (Check on), others (Check off) 

4. [Apply]  
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▶Fig. 8.22 

Message for a 
successful run 
 

2.7 Perform Analysis 

Analyze the 4 Models.  

 

Main Menu: Analysis / Perform Analysis  

1. Display Element Numbers (Toggle off) 

2. Check for successful completion in Message Window. 

 

 

 

In case the above message fails to appear, then the previous input must be checked again.  
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02.8.1 반력 

 
 

 

 

 
 

 

 
 

 

 
 

 

 
 

 

 

 

 

▶그림 8.23 

절점하중에 의한 반력 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 8.23 

Reactions due to nodal 
load 

 

2.8 Check Analysis Results 

Model 1: Due to the weak stiffness of the elastic link element, the concentrated load applied 

at the end of the left beam at Node 6 is largely resisted by the left side beam.  

Model 2: As the rotational stiffness of the left side beam support is small and the link stiffness 

is large, the concentrated load is transferred to the right side beam. 

Model 3: Due to the large stiffness of supports and elastic link element, the results are very 

similar to those of Model 4, which is fixed at both ends with an internal hinge. 

 

Main Menu: Results / Reactions / Reaction Forces/Moments... 

1. Load Cases / Combinations > ST: Nodal load 

2. Components > FZ, Type of Display > Values (Check on) 

3. [Apply]  
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▶Fig. 8.24 

Deformation due to 
nodal load 
 

 

The displacement of the left side beam in Model 1 does not influence the right side beam.  

However, similar displacements in the left and right side beams are observed in Models 2 and 

3. 

 

Main Menu: Results / Deformations / Deformed Shape... 

1. Load Cases / Combinations > ST: Nodal load 

2. Components > DXZ  

3. Type of Display > Undeformed, Legend, Values (Check on) 

4. Click [...] next to Deform and input Deformation Scale Factor: ‘2’  

5. Apply upon OK (Check on), [OK]  

6. Change the length unit to mm in Status Bar at the bottom of screen. 
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▶그림 8.25 

절점하중에 의한 휨모

멘트 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 8.25 

Bending moments due 
to nodal load 
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As the stiffness of an elastic support increases, the structural behavior begins to resemble a 

fixed support.  Hence a point spring support or an elastic link is used to control the stiffness 

of supports or elements.  They are also used to model the stiffness and eccentricity of a 

support. 

 

Main Menu: Results / Forces / Beam Diagrams... 

1. Load Cases/Combinations > ST: Nodal load 

2. Components > My  

3. Type of Display > Contour, Values, Legend (Check on), Deform (Check off) 

4. Click [...] next to Values 

5. Min & Max Only, Abs Max (Check on), Limit Scale (%): ‘20’ 

6. [OK]  

7. Change the length unit to m in Status Bar at the bottom of screen. 
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▶Fig. 8.26 

 
 

  

Fig. 8.26 shows a structure consisted of 2 beams connected by a spring.  If the center spring 

is removed, the structure becomes 2 statically determinate structures, which suggests that 

the degree of indeterminacy of the spring connected structure is 1.   If the left side beam 

deforms by 𝛿1 , and the right side beam deforms by 𝛿2 , the difference becomes the 

deformation of the spring, which renders a compatibility equation.   

 

The left side beam is rotationally restrained by a spring at the support.  The spring constant 

is 𝑘1.  The right side beam is supported by a vertical spring whose spring constant is 𝑘3.  

 

5.0 m 5.0 m

1
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1
k
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k

 

 

 

If the left side beam resists a force, Q under the concentrated load of 100 kN, the force resisted 

by the spring and the right side beam is 100-Q.  The following compatibility condition can be 

derived, which leads to the calculation of the force Q.  

3. Manual Calculations 

 



 

 

8. Springs Analysis Structural Analysis I  

(Basic) 

8 - 31 

1 - 31 

 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

 

▶표 8.3   
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Calculation results (Units: kN, m) 

 

model k1 k2 k3 Q 100-Q δ 1 δ 2 

1 1.0×106 10 1.0×105 99.7325 0.26750 2.682×10-2 0.7×10-4 

2 100 1.0×105 1.0×105 0.10535 99.89465 2.636×10-2 0.3×10-4 

3 1.0×106 1.0×105 1.0×105 49.53079 50.46921 1.332×10-2 -1.258×10-2 

 

 where, E=2.05 ×108 kN/m2, I=8.333×10-4 m4 
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1. Compare the reactions, displacements and member forces of the 2 structures of different 

boundary conditions.  Material and section are identical to those in Tutorial. 

 

1
.0

 m
5.0 m 5.0 m
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 m
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 m
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2. Compare the behaviors of the structure subjected to temperature loads due to 3 different 

cases of spring types using tension-only spring and compression only spring.  Material 

and section are identical to those in Tutorial.   

 

5.0 m 5.0 m

k1T
2T

 

 

Model 
Spring stiffness (kN·m) Load case 1 Load case 2 

Tension Compression T1 T2 T1 T2 

1 10,000 - -58 +58 +58 -58 

2 - 10,000 -58 +58 +58 -58 

3 10,000 10,000 -58 +58 +58 -58 

 

 

4. Exercise 
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▶Fig. 9.1  

Specified displacement 

 
 
 
 
 
 
 
 
 
 
 

 

 
 

 
 

 

 

 

 

 

 

 

 

 

 

▶그림 1.1  

단순보 

 

 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

식 1.1  

 

 

1.1 Concept for Specified Displacement 
Analysis 

Specified Displacements are used to analyze a structure when displacements of a specific 

point in certain degrees of freedom are known.   

 

Application areas include: 

 Condition assessment of a structure, which has already deformed 

 Analysis of a structure subjected to specific displacements as boundary conditions.  

(detail analysis of local parts based on global structural displacements)  

 Analysis of ground settlement effects 

 

 
 

 

 

A specified displacement is equivalent to applying a displacement load.  Instead of applying 

a conventional load, a specific displacement is applied, which in turn leads to finding the 

corresponding conventional load.  Fig. 9.2 shows a 2-span continuous beam with settlement 

(specified displacement) at the mid span support.  The loading and settlement are 

downward (negative sign) and the reaction is upward (positive sign). 

  

1. Introduction 
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▶Fig. 9.2 

Continuous beam with a 
specified displacement  
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Removing the effect of a vertical load, 𝑞 from the specified displacement, ∆ leaves the role 

of the reaction (concentrated load), 𝑋 as follows:  
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Given the specified displacement, ∆, the support reaction, 𝑋 can be calculated.  Fig. 9.3 is a 

graph showing the reaction ratio to the settlement ratio at Point B.  The settlement ratio is the 

settlement divided by the span length.  The reaction ratio represents the reaction value, 𝑋 

divided by the reaction corresponding to no settlement.  
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▶Fig. 9.3 

Relationship between 
settlement ratio and 
reaction ratio 
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Fig. 9.3 is constructed for 3 different magnitudes of vertical load, 𝑞 (10 kN/m, 0 kN/m, 

-10 kN/m).  When the vertical load, 𝑞 is downward (10 kN/m), the value 𝑋 becomes smaller, 

which means that the reaction at Point B becomes smaller.  If the vertical load is upward (-

10 kN/m), the value 𝑋 becomes larger because the settlement needs to take place while 

resisting the upward load.  
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▶Fig. 9.4 

Analysis model 

2.1 Model Overview 

Examine the reactions, deformations and member forces of a 2-span continuous beam 

subjected to a uniformly distributed load on Elements 1 and 2 and settlements at Nodes 2 

and 3.   

 

Compare the patterns of support reactions and member forces between the cases of before 

and after the settlements.  
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X
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1 2 31 2
 

 

 Material 

Modulus of elasticity (E): 30,000 N/mm2 

 Section 

Area (A): 1m2 

Moment of inertia (Iyy): 1.0 × 109 mm4 

 Load 

1. Uniformly distributed load: 10 kN/m 

2. Support settlements, 40 mm at Node 2 and 25 mm at Node 3 

Origin in GCS 

2. Tutorial 
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▶그림 9.2  

파일 저장 

단위계 설정 

 

 

 

 

 

 

 

 
 
 

 

 

 

 

 

 

 

 

 
 
 
 
 
 
 
 
 

▶Fig. 9.5  

Save file &  
set unit system 

2.2 Work Environment 

 Open a New File and save. 

 

Main Menu:  / New Project... 

Main Menu:  / Save As... 

1. File name: ‘SDP’ and [Save]  

 

 

 Set a unit system.  

 

Main Menu: Tools / Unit System...  

1. Length > mm, Force (Mass) > N (kg)  

2. [OK]  
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▶Fig. 9.6  

Set a work plane 
 

 

 The example model exists in the 2-D X-Z plane. 

 

Main Menu: Structure / Structure Type  

1. Structure Type > X-Z Plane  

2. [OK]  
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▶그림 9.1  

재질 정의 

단면 정의 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 9.7 

Define material & section 
 
 

2.3 Material & Section Properties 

Define material and section for the structural members, which are user-defined (User Defined 

Type & Value Type). 

 

Main Menu: Properties / Material Properties  

1. [Add...], Name: ‘MAT’  

2. Elasticity data > Type of Design > User Defined  

3. User Defined > Modulus of Elasticity: ‘3e+4’N/mm2  

4. [OK]  

5. Properties dialog window: click Section tab, [Add...], Value tab, Name: ‘SECT’  

6. Section Properties > Area: ‘1’mm2, Iyy: ‘1e+9’ mm2 

7. [OK], [Close]  
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▶Fig. 9.8 

Create nodes 
 
 

2.4 Nodes & Elements Generation 

Change the units to m, kN.  Create Nodes.  

 

Main Menu: Tools / Unit System > check on m, kN, [OK] 

Main Menu: Node/Element / Create Nodes  

1. Coordinates (x, y, z): ‘0, 0, 0’  

2. Number of Times: ‘2’ 

3. Distance (dx, dy, dz): ‘4.5, 0, 0’ 

4. [Apply]  

5. Display Node Numbers, Auto Fitting, Front View (Toggle on) 
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02.4.1 Create Nodes 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 9.8  

Create nodes 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 9.9 

Create beam elements 
 
 

 

Create beam elements by connecting nodes.  

 

Main Menu: Node/Element / Create Elements  

1. Element Type > General beam/Tapered beam  

2. Material > 1: MAT, Section > 1: SECT  

3. Click the Nodal Connectivity entry field (which turns to green),  

Click Nodes 1 and 3 on the model view sequentially. 
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▶Fig. 9.10 

Input support conditions 
 
 
 
 

2.5 Define Boundary Conditions 

Define boundary conditions at each support of the beam. 

Node 1 is fixed (Dx, Dz, Ry).  Nodes 2 and 3 are rollers (Dz).  Since the Dz degree of 

freedom is automatically restrained when Nodes 2 and 3 are defined with support 

settlements by specified displacements, only Node 1 will be defined with the boundary 

condition.    

 

Main Menu: Boundary / Define Supports  

1. Support Type (Local Direction) > Dx, Dz, Ry (Check on)   

2. Select Single (on) mode: select Node 1 

3. [Apply]  

4. Support Type (Local Direction) > Dz (Check on) 

5. Select Single (on) mode: select Node 2, 3 

6. [Apply] 
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07.1 하중조건 정의 

 
 

 

 

 

 

 
 
 
 
 
 
 
 
 
 

▶Fig. 9.10 

Input support conditions 
 
 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 9.11 

Define load cases 
 
 
 
 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 

 

2.6 Define Loads 

Define load cases to specify a uniformly distributed load and specified displacements caused 

by support settlements.   

 

Main Menu: Load / Static Loads / Static Load Cases  

1. Name: ‘UDL’  

2. Type > User Defined Load (USER)  

3. [Add]  

4. Name: ‘Support settlements’  

5. Type > User Defined Load (USER)  

6. [Add]  

7. [Close]  
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▶그림 9.1  

등분포 하중 입력 

 

 
Relative와 Absolute 

 

 

 
 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 9.12 

Input UDL 
 
 
 

 

Define a uniformly distributed load, 10 kN/m in the gravity direction. 

  

Main Menu: Load / Static Loads / Element Beam Loads... 

1. Display (Toggle on), Load tab > Load Value (Check on), [OK] 

2. Display Element Numbers (Toggle on) 

3. Load Case Name > UDL 

4. Load Type > Uniform Loads  

5. Direction > Global Z  

6. Value > Relative, x1: ‘0’, w: ‘-10’, x2: ‘1’  

7. Select Single (on) mode > select Elements 1 & 2 

8. [Apply]  
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▶Fig. 9.13 

Input specified 
displacement 
 
  
 
  

 

 

Input support settlements using Specified Displacements of Supports. 

 

From the Status Bar at the bottom of the screen, change the length unit to mm.  

Main Menu: Load / Specified Displacements of Supports... 

1. Load Case Name > Support settlements 

2. Displacements (Local Direction) > Dz: ‘-40’  

3. Select Single (on) mode: select Node 2 

4. [Apply] 

5. Displacements (Local Direction) > Dz: ‘-25’  

6. Select Node 3 

7. [Apply]  
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▶Fig. 9.14 

Message for a 
successful run 
  
 

2.7 Perform Analysis 

Analyze the model.  

 

Main Menu: Analysis / Perform Analysis  

1. Display Node Numbers, Display Element Numbers (Toggle off) 

2. Check for successful completion in Message Window. 

 

 

 

 

In case the above message fails to appear, then the previous input must be checked again. 
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09.1 하중조합 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶그림 9.1   

하중조합조건 

  
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 9.15 

Combine loads 
  
 

2.8 Check Analysis Results 

Using the load cases defined, create a load combination. 

Load Combination: 1.0 Uniform Load + 1.0 Settlement 

 

Main Menu: Results / Load Combination 

1. Load Combination List > Name: ‘LCB’’ 

2. Description: ‘UDL + Support settlements’  

3. Load Cases and Factors > LoadCase > select UDL, Factor: ‘1.0’  

In the next row, select Support settlements, Factor: ‘1.0’  

4. [Close]  
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▶Fig. 9.16 

Deformation due to 
specified displacements 
 

 

Check the deformed shape. 

Note the settlements specified at Nodes 2 and 3 (40 mm & 25 mm respectively). 

 

Main Menu: Results / Deformations / Deformed Shape... 

1. Load Cases/Combinations > CB: LCB  

2. Components > DXZ  

3. Type of Display > Undeformed, Legend, Values (Check on) 

4. Click [...] next to Deform 

5. Deformation Scale Factor: ‘2’ 

6. Deformation Type > Real Deform  

7. Apply upon OK (Check on), [OK] 
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 Check the deformation due to the UDL, Support settlements and LCB. 

 

From the Status Bar at the bottom of the screen, change the length unit to m 

1. Main Menu: View / New Window  

2. Front View (Toggle on) 

3. Main Menu: View / New Window  

4. Front View (Toggle on) 

5. Main Menu: View / Tile Horizontally  

6. Adjust the arrangement of windows, Model View, Model View: 1, Model View: 2 for 

   ease of comparison 

 

7. Click Model View tab 

8. Main Menu: Results / Reactions / Reaction Forces/Moments... 

9. Load Cases/Combinations > ST: UDL 

10. Components > FZ  

11. Type of Display > Values (Check on), Legend (Check off) 

12. [Apply] 

 

13. Click Model View: 1 tab  

14. Main Menu: Results / Reactions / Reaction Forces/Moments... 

15. Load Cases/Combinations > ST: Support settlements 

16. Components > FZ  

17. Type of Display > Values (Check on), Legend (Check off) 

18. [Apply]  

 

19. Click Model View: 2 tab 

20. Main Menu: Results / Reactions / Reaction Forces/Moments... 

21. Load Cases/Combinations > CB: LCB  

22. Components > FZ  

23. Type of Display > Values (Check on), Legend (Check off) 

24. [Apply]  
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▶ 그림 9.17 

각 하중조건별 반력 비

교 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 
▶ Fig. 9.17 

Reactions due to UDL, 
Support settlements and 
LCB 
 
 
 
 
 
 
 
 
 

 

 

 

 

 

 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 

▶ Fig. 9.17 

Compare reactions from 
each load case 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

 

It can be observed in the UDL case that the reaction at Node 2 is more than that from the 

tributary length due to the continuity.  In the Support settlements case, a negative reaction 

appears at Node 2 where the settlement is the greatest.  LCB case shows the summation 

of the load cases. 
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Compare the moments among the load cases and combination. 

 

1. Click Model View tab 

2. Main Menu: Results / Forces / Beam Diagrams... 

3. Load Cases/Combinations > ST: UDL 

4. Components > My  

5. Type of Display > Contour, Values (Check on), Legend, Deform, Undeformed 

  (Check off) 

6. Output Section Location > All (Check on) 

7. [Apply]  

 

8. Click Model View: 1 tab 

9. Main Menu: Results / Forces / Beam Diagrams... 

10. Load Cases/Combinations > ST: Support settlements 

11. Components > My  

12. Type of Display > Contour, Values (Check on), Legend, Deform, Undeformed 

   (Check off) 

13. Output Section Location > All (Check on) 

14. [Apply]  

 

15. Click Model View: 2 tab 

16. Main Menu: Results / Forces / Beam Diagrams... 

17. Load Cases/Combinations > CB: LCB  

18. Components > My  

19. Type of Display > Contour, Values (Check on), Legend, Deform, Undeformed 

   (Check off) 

20. Output Section Location > All (Check on) 

21. [Apply]  
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▶ Fig. 9.18 

Compare bending 
moments for each load 
case and combination  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

 

Specified displacement analysis is used to investigate the global behavior of a structure due 

to support settlements.  Specified displacement analysis is also used to investigate local 

effects (stress) of a specific part of the total structure using the deformation results obtained 

from the global analysis.   
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▶ Fig. 9.1 

 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

As the problem pertains to support settlements, the following expression can be derived 

through flexibility method or consistent deformation method.  

 

 

 

𝑓11 and 𝑓12in Fig. 9.19 represent the displacements at Points B and C respectively when a 

unit load is applied at Point B.  𝑓21 and 𝑓22 represent the displacements at Points B and C 

respectively when a unit load is applied at Point C.  𝐷1 and 𝐷2 are the displacements at 

Points B and C respectively when the loading is applied to the structure while the supports 

are removed from Points B and C.  
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3. Manual Calculations 
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3 3 3

17 2
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f f f f
EI EI EI

D D
EI EI

 

 

Using the above results, the following can be expressed for the uniformly distributed load and 

the settlements taking place simultaneously: 

 

1

2

1.013 2.531 96.820 40

2.531 8.100 273.375 25

X

X

       
       

       
 

 

The first left term above signifies upward displacements at the supports when the unknown 

support reactions ( X ) are acting.  The second left term represents downward 

displacements ( D ) at the supports caused by the actual load.  So the left side of the above 

equation represents the sum of the displacements ( D ) due to the load and the 

displacements ( FX ) due to the reactions.  If no settlements are present, then the right term 

must be zero.  If settlements have occurred, then the right term must be the actual 

displacements at the supports (Δ ).    

 

1) If the load is applied, and no settlements exist, 

 

1

2

1.013 2.531 96.820 0

2.531 8.100 273.375 0

      
       

      

X

X

 
1

2

51.429 kN

17.679 kN

X

X




 

 

2) If only the settlements exist without any load, 

 

1

2

1.013 2.531 0 40

2.531 8.100 0 25

      
       

      

X

X

 
1

2

145.326 kN

42.428 kN

X

X

 


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3) If the loading is applied, and the settlements exist at the same time,  

 

1

2

51.429 145.326 93.898 kN

17.679 42.428 60.007 kN

   

  

X

X
 

 

The above results are identical to those from the analysis results in midas Gen.  The fourth 

decimal values have been rounded off.    
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1. Compare the bending moments of the 2 models below.  

 

(a) 

 

(b) 

3 54

5 m 5 m
 

 

 

 Material 

Steel: IS(S), DB > Fe 570 (E = 2.0500×108 kN/m2) 

 Section 

B × H: 400 mm × 600 mm (Area=2.4 × 10-1 m2, Iyy = 7.2 × 10-3 m4) 

 Load 

Model 1: a concentrated load, 70 kN in the gravity direction at the mid span  

Model 2: a settlement, 10mm at Node 4  

  

4. Exercise 

 
70 kN

10 m

1 2
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2. Find the shear force and bending moment diagrams of the portal frame below subjected 

to a settlement, 10mm at Node 2.  

 

6 m

4
 m

X

Z

1

3 4

2

1

3

2

 

 

 

 Material 

Steel: IS(S), DB > Fe 570 (E = 2.0500×108 N/mm2) 

 Section 

I Shape: (Area=21454 mm2, Iyy = 6.5362 × 108 mm4) 

 Load 

Settlement at right column (Node 2): 10 mm 
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1.1 Concept for Moving Load Analysis 

Moving load analysis in midas Gen is used to reflect static (vehicle) moving loads as follows:  

 

 Calculation of influence line and influence surface of displacements, member 

forces, reactions, etc. due to a unit moving load 

 Calculation of max/min nodal displacements, member forces, reactions, etc. due 

to moving loads using the influence line and influence surface 

 

The prime objective of moving load analysis is to investigate the maximum and minimum 

effects of moving live loads or vehicular loads, which are momentarily positioned at various 

locations along the entire moving path.  Rather than analyzing the structure for various 

moving load positions repeatedly, influence line and influence surface analyses enable the 

engineer to identify the critical moving load positions, which cause the maximum/minimum 

effects (displacements, member forces, reactions, etc.).   

 

In case of a vehicular load, the traffic lane or surface of the vehicle and the method of 

loading the vehicle are defined.  Influence line (for 1D elements) or influence surface (for 

2D elements) is then calculated by placing a unit moving load on the traffic lane or surface.     

 

Influence line is obtained through static analysis results of each component (such as force 

reaction or displacement) at a specific point on a beam or truss caused by a unit load placed 

at any point along the structure.  Similarly influence surface is obtained by placing a unit 

load at nodes of plate elements, the static analysis results of which are presented at the 

corresponding loaded nodes.    

 

 

 

 

 

 

 

 

1. Introduction 

http://en.wikipedia.org/wiki/Beam_(structure)
http://en.wikipedia.org/wiki/Truss
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The process of moving load analysis using an influence line or influence surface is simply 

summarized as follows:  

 

Step 1: Define a vehicle load, the method of loading the vehicle and traffic line or 

surface. 

Step 2: Create a unit load case for which static analysis is performed for each resulting 

component at various loading positions, resulting in an influence line or surface. 

Step 3: Obtain analysis results for the moving load based on the loading method using 

the influence line or surface.  

 

The moving load analysis through the above process results in maximum and minimum 

effects for each moving load condition, which can be combined with other loading cases.  

Because of load combinations with the maximum and minimum moving load results, the 

combined results will in turn retain maximum and minimum results.  Analysis result 

component may be nodal displacements, support reactions and member forces of truss, 

beam and plate elements.    

 

A unit load applied in the process of obtaining an influence line or influence surface used in 

moving load analysis acts in the -Z direction in Global Coordinate System.  An unlimited 

number of moving load analysis cases can be used.     

 

The principle of Müller-Breslau states that the influence line is the deformed shape of a 

structure from which reactions or section forces are removed and a unit displacement is 

applied to the corresponding positions.  The reactions, section forces, etc. of the structure 

can be found from the shape of the influence line.  Fig. 10.1 and Fig. 10.2 show the 

influence lines of a simply supported beam and a 2-span continuous beam. 
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▶Fig. 10.1 (Left) 

(a) Influence lines (IL) of a simply 
supported beam 

(b) (a) Moving load analysis 
model 

(c) (b) Reaction ( AR ) IL 

(d) (c) Reaction ( BR ) IL 

(e) (d) Shear force (
CV ) IL 

(f) (e) Bending moment (
CM ) IL 

 
 
 

▶Fig. 10.2 (Right) 

(g) Influence lines (IL) of a 2-span 
continuous beam 
(a) Moving load analysis 
model 

(h) (b) Reaction ( AR ) IL 

(i) (c) Reaction ( BR ) IL 

(j) (d) Shear force ( CV ) IL 

(e) Bending moment ( CM ) IL 

(f) Bending moment ( BM ) IL 
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(f) - 

 

 

For the simply supported beam, influence lines of reactions at Points A and B, and shear 

force and moment at a specific location are indicated.  For the continuous beam, influence 

lines of reactions at Points A and B, shear force and moment at Points B and C together 

with reaction at D are indicated.  The influence lines of the simply supported beam are 

straight lines as the structure is statically determinate; whereas, curved influence lines 
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▶그림 10.3 

B점의 회전각 및 모멘

트 

 

 

 

 
 

 

 
 

 

 
 

 

 

▶식 10.1 

 

 

 
 

 

 
 

 

 
 

 

 
 

 
 

 

 
 
 
 
 
 
 
 
 
 
 

▶Fig. 10.3 

Rotation angle and 
moment at Point B 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Eq. 10.1 

 

prevail in the continuous beam due to its statically indeterminacy.  Calculating the value 

represented by at the acting point of loading in the influence line will become the reaction 

or section force when the loading acts on the corresponding position.  

 

In order to investigate the method of computing section forces due to a moving load using 

an influence line, the center negative moment, BM (Fig. 10.2(f)) of the continuous beam will 

be calculated.  As it pertains to an influence line for moments, a hinge is inserted in Point B, 

thus releasing the moment, and a moment is applied to Point B such that a unit rotation 

angle takes place.  The deformed shape at that instance becomes an influence line.  The 

 value at the mid span of the span AB is the BM value when the moving load is 

positioned at the point.  By the symmetry about Point B,  can be obtained for a simply 

supported beam to which M is applied at one end.  The rotation angle at Point B is as 

shown in Fig. 10.3.  For a unit rotation angle to occur at Point B, the following magnitude of 

moment needs to be applied at each side of Point B.  

 




M

3


M

EI


2

16
 

M

EI
 

 

2 1
3

 
lM

EI
, or 

3

2

l

EI
M  

 

 

The deformed shape of the beam subjected to the above moment becomes the influence 

line.  The deflection at the mid-span as shown in Fig. 10.3 can be calculated as follows:  

 

2 23 3

16 2 16 32
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▶Fig. 10.4 

Moment diagram of 2-
span continuous beam 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Eq. 10.2 

 

 

In the 2-span continuous beam, the moment diagram due to a unit load applied at Point C 

(mid-span of Span AB) is as shown in Fig. 10.4 in which case the influence line value can 

be observed to become equal to the negative moment at Point B.    
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The concept of influence line can be explained by the principle of virtual work.  Fig. 10.1(b) 

shows the influence line of the reaction AR at Point A when the simply supported beam is 

subjected to a concentrated load.  Applying the principle of virtual work, the work done in 

Fig. 10.1(b) by the force AR and 1 in Fig. 10.1(a) is as follows:  

 

1 1 0E AW R      

 

In this equation, the work done ( EW ) by the external force must be zero.  Since no 

deformation takes place in the beam, the work done ( iW ) by the internal force is zero.  

Hence the reaction, AR becomes equal to the deflection, . 
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▶Fig. 10.5 

Analysis model 
 
 
 
 
 
 

2.1 Model Overview 

Calculate the maximum section forces by different member locations of a single span beam 

due to a moving load using an influence line. Check the position of the moving load, which 

causes the maximum section force.  

 

                  

 

 

 

 Material 

Concrete IS(RC) M30 (Modulus of elasticity, E = 2.7386×107 kN/m2) 

 Section 

Shape: Solid Rectangle  

Dimension: BH = 3.0 m×1.0 m  

 Load 

Concentrated Load: 10kN 

2. Tutorial 
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2.2 Work Environment 

Open a New File and save. 

 

Main Menu:  / New Project...  

Main Menu:  / Save...  

1. File name: ‘Moving Load’ and [Save]  

 

 

Set a unit system to kN & m.  

 

Main Menu: Tools / Unit System 

1. Length > m, Force (Mass) > kN(ton)  

2. [OK]  

 

 

 

 

  

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 10.6 

Save file &  
set unit system 
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The example model exists in the 2-D X-Z plane.  Set Structure Type to X-Z Plane. 
 

Main Menu: Structure / Structure Type  

1. Structure Type > X-Z Plane  

2. [OK]  

 

 

 
  

 

 
 
 
 
 
 
 
 
 
 
 

▶Fig. 10.7 

Set a work plane 
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2.3 Material & Section Properties 

Define material and section for the structural members.   

 

Main Menu: Properties > Material Properties 

1. [Add...], Type of Design > Concrete   

2. Concrete > Standard > IS(RC), DB > M30 

3. [OK]  

4. Properties dialog window: click Section tab, [Add…], DB/User tab > Solid Rectangle 

5. Name: ‘Beam’, Select User  

6. H: ‘1’, B: ‘3’  

7. [OK], [Close] 

 

   

 
   

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 10.8 

Define material 
Define section 
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2.4 Nodes & Elements Generation 

Create nodes at the start, end, locations of loads and boundaries and the locations for 

checking the results.  

 

Main Menu: Node/Element > Create Nodes 

1. Coordinates (x, y, z): ‘0, 0, 0’  

2. [Apply]   

3. Auto Fitting, Front View (Toggle on) 

 

 
 

 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 10.9 

Create a node 
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Use Extrude Elements to extend a node to line elements thus creating a continuous beam.  

 

Main Menu: Node/Element > Extrude 

1. Select Extrude Type > Node → Line Element  

2. Select Element Attribute > Element Type > Beam  

3. Material > 1: M30, Section > 1: Beam, Beta Angle: ‘0’  

4. Generation Type > Translate 

5. Translation > Equal Distance 

6. dx, dy, dz: ‘1, 0, 0’, Number of Times: ‘20’  

7. Click Select All  

8. [Apply]  

 

 

 

 

  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 10.10 

Create beam elements 
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2.5 Define Boundary Conditions 

Create supports for the continuous beam.  

A pin condition restrains Dx and Dz degrees of freedom, and a roller condition restrains only 

Dz degree of freedom.  

 

Main Menu: Boundary / Define Supports 

1. Display Node Numbers (Toggle on) 

2. Options > Add, Support Type > D-ALL (Check on) 

3. Select Single (on) mode: select Node 1, then [Apply] 

4. Support Type > Dx (Check off), Rx (Check on) 

5. Select Single (on) mode: select Nodes 21, then [Apply]  

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 10.11 

Define support 
conditions 
 1 

2 

3,5 

3,5 

2,4 



 

 

10. Moving Load Analysis 

10 - 15 

Structural Analysis I  

(Basic) 

2.6 Define Loads 

In order to calculate the member forces due to a moving load, an influence line must be 

calculated in advance.  Define a traffic lane before calculating the influence line. As the 

beam is simply supported, calculate the impact factors corresponding to span length.    

 

Main Menu: Load / Moving Load / Moving Load Code  

1. Moving Load Code > India 

 

Main Menu: Load / Moving Load / Traffic Line Lanes 

1. Click [Add] 

2. Lane Name: ‘Lane1’ 

3. Eccentricity: ‘0’, Wheel Spacing: ‘0’  

4. Impact Factor: ‘0’  

5. Selection by > 2 Points > Click Nodes 1, 21 

6. [OK]  

7. After checking Lane1 in the Traffic Line Lanes list, [Close] 
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▶Fig. 10.12 

Define traffic lane 
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The moving load (User Defined Vehicle Class 70R - Boogie) is defined using the the 

program. 

 

Main Menu: Load / Moving Load / Vehicles 

1. Click [Add User Defined] 

2. Load Type > Wheeled/Tracked/Bogie 

3. Vehicular Load Properties > Vehicular Load Name: ‘Vehicle 1, 

  4. Wheeled vehicles > P# : 10kN , D# : 0m, Click > Add 

  5. Minimum Nose to tail distance : 0m 

  6. [OK]  

  7. Check to see Vehicle 1’ in the Vehicles list, then [Close] 

 

 

 

 

 

 
 

 

  

 

 

 

 

  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 10.13 

Define moving load 
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Define vehicle load group used for moving load analysis.  

 

Main Menu: Load / Moving Load / Moving Load Cases 

1. [Add]  

2. Vehicle Class Name: ‘Case 1 

3. Check off > Auto Live Load Combination 

4. Click on > Add 

5. Input the data, 

Min Number of loaded lanes > 0  

Max Number of loaded lanes > 1 

Select the vehicle > Vehicle 1 

6. From the List of Lanes list, click Lane 1 followed by clicking [  ] 

7. Check to see Case 1 in the Selected Load list, then [OK] 

8. [Close]  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 

▶Fig. 10.14 

Define moving load 
cases 
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  2.7 Perform Analysis 

Analyze the model.  

 

Go to Analysis / Moving Load 

Input the maximum successive vehicles : 1 

Main Menu: Analysis / Perform Analysis  

1. Display Node Numbers (Toggle off) 

2. Check for successful completion in Message Window. 

 

 

 

 

In case the above message fails to appear, the previous input must be checked again. 

 

 

 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
▶Fig. 10.15 

Message for a 
successful run 
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2.8 Check Analysis Results 

Check the influence line for the reaction at the support Node 1. 

 

Main Menu: Results / Influence Lines / Reaction... 

1. Hidden (Toggle off), Iso View (Toggle on) 

2. Line/Surface Lanes > Lane 1  

3. Key Node: ‘1’, Scale Factor: ‘2’ 

4. Components > FZ  

5. [Apply]  

 

 

 

  

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 10.16 

Influence line for reaction 
at Node 5 
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Check the influence line for moment at j-End of Element 4.  

 

Main Menu: Results / Influence Lines / Beam Forces/Moments... 

1. Display Node Numbers (Toggle off), Display Element Numbers (Toggle on) 

2. Line/Surface Lanes > select Lane 1, Key Element: ‘4’, Scale Factor: ‘2’  

3. Parts > i  

4. Component > My Type of display > Values 

5. [Apply]  
 

 

 

 

 

 

 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 

▶Fig. 10.17 

Influence line for j-End 
moment of Element 4 
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Check the moment due to the moving load. 

 

Main Menu: Results/ Forces / Beam Diagrams... 

1. Display Element Numbers (Toggle off), Front View (Toggle on) 

2. Load Cases/Combinations > MVmax: Case1  

3. Components > My  

4. Display Options > 5 Points  

5. Type of Display > Contour, Values (Check on) 

   Click [...] next to Values, MinMax Only, Abs Max (Check on),  

Check on Set Orientation, enter ‘0’, Apply upon OK (Check off), [OK]  

  Output Section Location > All  

  [Apply]  

 

  

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
▶Fig. 10.18 

Negative moment due 
to moving load 
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From the above diagram, it can be observed that the maximum moment takes place at j-

End of Element 12 (Node 12) due to the moving load.  At this instance, the position of the 

moving load is examined, which is determined by the influence line.  From the diagram 

below, the position of the moving load, which causes the maximum negative moment, can 

be identified on the influence line. 

 

Main Menu: Results / Moving Tracer / Beam Forces/Moments... 

1. Display Element Numbers (Toggle on) 

2. Moving Load Cases > MVmax: Case 1 

3. Key Element: ‘12’, Scale Factor: ‘2’  

4. Parts > i  

5. Components > My  

6. Type of Display > Contour, Applied Loads (Check on) 

7. [Apply]  

 

 

 

 
 
 

▶Fig. 10.19 

Position of moving load 
which causes the 
maximum negative 
moment at j-End of 
Element 4 
 

Influence line 

1 

4 

5 

6 

2~3 



 

 

10. Moving Load Analysis 

10 - 24 

Structural Analysis I  

(Basic) 

 

The wheel load of 10kN is considered.  Fig. 10.21 below shows the position of the vehicle, 

which causes the maximum moment at Point B from the influence line analysis by midas 

Gen, and the influence line at that instance. The values of the influence line in Fig. 10.21 

have been linearly interpolated from the analysis results.  The maximum moment at Point 

B is thus obtained from the following:  

 

MB max = 10 x 4.95 = 49.5 kN m 

 

 

 

 

 

 

 

 

 

 

midas Gen produced the maximum moment of 49.5 kN m   

  

 

 
▶Fig. 10.20 

Influence line calculation 
results 
 

3. Manual Calculations 
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Find the maximum moment, shear and reaction of the simply supported beam below 

subjected to a moving load whose loaded length is longer than the span.  Find the position 

of the moving load causing the maximum of each force component.  Material and section 

properties are the same as those in Tutorial.  
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